Oracle Linux 7:samba (ELSA-2021-2313)

medium Nessus 插件 ID 150425
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Oracle Linux 主机缺少安全更新。

描述

远程 Oracle Linux 7 主机上安装的程序包受到 ELSA-2021-2313 公告中提及的漏洞的影响。

- 在 samba 中发现一个缺陷。Samba smbd 文件服务器必须将 Windows 群组标识 (SID) 映射到 unix 群组 ID (gids)。执行此任务的代码有一个缺陷,在将负缓存条目添加到映射缓存时,该缺陷允许应用程序读取超出数组末尾的数据。这可造成调用代码将这些值返回至为用户存储组成员身份的进程标记中。此漏洞最主要的威胁对象是数据机密性和完整性。
(CVE-2021-20254)

请注意,Nessus 尚未测试此问题,而是只依赖于应用程序自我报告的版本号。

解决方案

更新受影响的程序包。

另见

https://linux.oracle.com/errata/ELSA-2021-2313.html

插件详情

严重性: Medium

ID: 150425

文件名: oraclelinux_ELSA-2021-2313.nasl

版本: 1.3

类型: local

代理: unix

发布时间: 2021/6/9

最近更新时间: 2021/6/25

依存关系: ssh_get_info.nasl

风险信息

CVSS 分数来源: CVE-2021-20254

VPR

风险因素: Medium

分数: 6

CVSS v2

风险因素: Medium

基本分数: 4.9

时间分数: 3.6

矢量: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:N

时间矢量: CVSS2#E:U/RL:OF/RC:C

CVSS v3

风险因素: Medium

基本分数: 6.8

时间分数: 5.9

矢量: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

漏洞信息

CPE: cpe:2.3:o:oracle:linux:7:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:libsmbclient:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:libsmbclient-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:samba:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:samba-client:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:samba-common:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:samba-winbind:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:samba-winbind-clients:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:samba-winbind-krb5-locator:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:libwbclient:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:libwbclient-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:samba-client-libs:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:samba-common-libs:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:samba-common-tools:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:samba-dc:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:samba-dc-libs:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:samba-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:samba-libs:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:samba-pidl:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:samba-python:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:samba-test:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:samba-test-libs:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:samba-vfs-glusterfs:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:samba-winbind-modules:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:ctdb:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:ctdb-tests:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:samba-krb5-printing:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:samba-python-test:*:*:*:*:*:*:*

必需的 KB 项: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/OracleLinux

易利用性: No known exploits are available

补丁发布日期: 2021/6/9

漏洞发布日期: 2021/4/29

参考资料信息

CVE: CVE-2021-20254

IAVA: 2021-A-0208