Apache 2.4.x < 2.4.47 多个漏洞

critical Nessus 插件 ID 150280
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器受到多个漏洞影响。

描述

远程主机上安装的 Apache httpd 版本低于 2.4.47。因此,该应用程序受到 2.4.47 更新日志中提及的多个漏洞的影响:

- 与“MergeSlashes OFF”匹配的非预期 <Location> 部分 (CVE-2021-30641)

- mod_auth_digest:验证摘要 nonce 时,一个 nul 字节可能发生堆栈溢出。(CVE-2020-35452)

- mod_session:修复可能因空指针取消引用而造成的崩溃,攻击者可能利用此问题造成恶意后端服务器和 SessionHeader 拒绝服务。(CVE-2021-26691)

- mod_session:修复可能因空指针取消引用而造成的崩溃,攻击者可能利用此问题造成拒绝服务。
(CVE-2021-26690)

- mod_proxy_http:修复可能因空指针取消引用而造成的崩溃,攻击者可能利用此问题造成拒绝服务。(CVE-2020-13950)

- Windows:防止本地用户停止 httpd 进程 (CVE-2020-13938)

- mod_proxy_wstunnel、mod_proxy_http:处理可升级协议端到端协商。(CVE-2019-17567)

请注意,Nessus 尚未测试此问题,而是只依赖于应用程序自我报告的版本号。

解决方案

升级至 Apache 2.4.47 或更高版本。

另见

https://downloads.apache.org/httpd/CHANGES_2.4

插件详情

严重性: Critical

ID: 150280

文件名: apache_2_4_47.nasl

版本: 1.3

类型: combined

代理: windows, macosx, unix

系列: Web Servers

发布时间: 2021/6/4

最近更新时间: 2021/9/24

依存关系: apache_http_version.nasl, apache_http_server_nix_installed.nbin, apache_httpd_win_installed.nbin

风险信息

CVSS 分数来源: CVE-2021-26691

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:apache:httpd, cpe:/a:apache:http_server

必需的 KB 项: installed_sw/Apache

易利用性: No known exploits are available

补丁发布日期: 2021/6/1

漏洞发布日期: 2021/6/1

参考资料信息

CVE: CVE-2019-17567, CVE-2020-13938, CVE-2020-13950, CVE-2020-35452, CVE-2021-26690, CVE-2021-26691, CVE-2021-30641

IAVA: 2021-A-0259-S