Amazon Linux AMI:ruby20 (ALAS-2021-1505)

high Nessus 插件 ID 149862
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Amazon Linux AMI 主机缺少安全更新。

描述

远程主机上安装的 ruby20 版本低于 2.0.0.648-2.40。因此,该应用程序受到 ALAS-2021-1505 公告中提及的漏洞的影响。请注意,Nessus 尚未测试此问题,而是只依赖于应用程序自我报告的版本号。

解决方案

运行 'yum update ruby20' 以更新系统。

另见

https://alas.aws.amazon.com/ALAS-2021-1505.html

https://access.redhat.com/security/cve/CVE-2021-31799

插件详情

严重性: High

ID: 149862

文件名: ala_ALAS-2021-1505.nasl

版本: 1.4

类型: local

代理: unix

发布时间: 2021/5/24

最近更新时间: 2021/8/30

依存关系: ssh_get_info.nasl

风险信息

CVSS 分数来源: CVE-2021-31799

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: Medium

基本分数: 4.4

时间分数: 3.3

矢量: AV:L/AC:M/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7

时间分数: 6.1

矢量: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:amazon:linux:ruby20, p-cpe:/a:amazon:linux:ruby20-debuginfo, p-cpe:/a:amazon:linux:ruby20-devel, p-cpe:/a:amazon:linux:ruby20-doc, p-cpe:/a:amazon:linux:ruby20-irb, p-cpe:/a:amazon:linux:ruby20-libs, p-cpe:/a:amazon:linux:rubygem20-bigdecimal, p-cpe:/a:amazon:linux:rubygem20-io-console, p-cpe:/a:amazon:linux:rubygem20-psych, p-cpe:/a:amazon:linux:rubygems20, p-cpe:/a:amazon:linux:rubygems20-devel, cpe:/o:amazon:linux

必需的 KB 项: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

易利用性: No known exploits are available

补丁发布日期: 2021/5/20

漏洞发布日期: 2021/5/20

参考资料信息

CVE: CVE-2021-31799

ALAS: 2021-1505