WordPress 5.7 < 5.7.1 / 5.6 < 5.6.3 / 5.5 < 5.5.4 / 5.4 < 5.4.5 / 5.3 < 5.3.7 / 5.2 < 5.2.10 / 5.1 < 5.1.9 / 5.0 < 5.0.12 / 4.9 < 4.9.17 / 4.8 < 4.8.16 / 4.7 < 4.7.20

medium Nessus 插件 ID 148844
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器上运行的 PHP 应用程序受到多个漏洞的影响。

描述

WordPress 5.7 < 5.7.1 / 5.6 < 5.6.3 / 5.5 < 5.5.4 / 5.4 < 5.4.5 / 5.3 < 5.3.7 / 5.2 < 5.2.10 / 5.1 < 5.1.9 / 5.0 < 5.0.12 / 4.9 < 4.9.17 / 4.8 < 4.8.16 / 4.7 < 4.7.20 受到多个漏洞的影响:

- 能够上传文件的用户(如作者)可利用媒体库中的 XML 解析问题,进而造成 XXE 攻击。这要求 WordPress 安装必须使用 PHP8。若 XXE 攻击成功,则可以获得内部文件的访问权限。(CVE-2021-29447)

- WordPress 编辑器中的一个区块可以通过暴露受密码保护的帖子和页面的方式遭到利用。这至少需要贡献者权限。(CVE-2021-29450)

请注意,Nessus 尚未测试此问题,而是只依赖于应用程序自我报告的版本号。

解决方案

升级到 WordPress 版本 5.7.1、5.6.3、5.5.4、5.4.5、5.3.7、5.2.10、5.1.9、5.0.12、4.9.17、4.8.16、4.7.10 或更高版本。

另见

http://www.nessus.org/u?00aa3f86

https://wordpress.org/support/wordpress-version/version-5-7-1/

https://wordpress.org/download/releases/

插件详情

严重性: Medium

ID: 148844

文件名: wordpress_5_7_1.nasl

版本: 1.8

类型: remote

系列: CGI abuses

发布时间: 2021/4/20

最近更新时间: 2021/9/16

依存关系: wordpress_detect.nasl

配置: 启用偏执模式

风险信息

CVSS 分数来源: CVE-2021-29450

VPR

风险因素: Medium

分数: 6.1

CVSS v2

风险因素: Medium

基本分数: 4

时间分数: 3.1

矢量: AV:N/AC:L/Au:S/C:P/I:N/A:N

时间矢量: E:POC/RL:OF/RC:C

CVSS v3

风险因素: Medium

基本分数: 4.3

时间分数: 3.9

矢量: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

时间矢量: E:P/RL:O/RC:C

漏洞信息

CPE: cpe:/a:wordpress:wordpress

必需的 KB 项: www/PHP, installed_sw/WordPress, Settings/ParanoidReport

可利用: true

易利用性: Exploits are available

补丁发布日期: 2021/4/15

漏洞发布日期: 2021/4/15

参考资料信息

CVE: CVE-2021-29447, CVE-2021-29450

IAVA: 2021-A-0182-S