NewStart CGSL MAIN 4.06:qemu-kvm 多个漏洞 (NS-SA-2021-0004)

medium Nessus 插件 ID 147408

语言:

全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程机器受到多个漏洞影响。

描述

运行 MAIN 4.06 版本的远程 NewStart CGSL 主机上安装的 qemu-kvm 程序包受到多个漏洞的影响:

- 在 QEMU 4.1.0 所使用的 libslirp 4.0.0 中,ip_input.c 的 ip_reass 存在释放后使用。(CVE-2019-15890)

- 由于未正确处理涉及首个碎片的情况,通过大型程序包,libslirp 4.0.0 的 ip_input.c 中的 ip_reass 存在基于堆的缓冲区溢出。(CVE-2019-14378)

- 在 QEMU 4.2.0 所使用的 libslirp 4.1.0 中,tcp_subr.c 误用 snprintf 返回值,导致随后的代码中出现缓冲区溢出。(CVE-2020-8608)

- 在 QEMU 4.2.0 所使用的 libslirp 4.1.0 中,tcp_subr.c 的 tcp_emu 未能正确管理内存,EMU_IRC 中的 IRC DCC 命令即为示例。此问题可能造成基于堆的缓冲区溢出或其他越界访问,进而导致 DoS 或可能执行任意代码。(CVE-2020-7039)

- 在版本低于 5.2.0 的 QEMU 的 USB 仿真器中发现越界读取/写入访问缺陷。USBDevice“setup_len”超过其在 do_token_in、do_token_out 例程中的“data_buf[4096]”时,在处理来自客户机的 USB 数据包时会发生此问题。客户机用户可利用此缺陷使 QEMU 进程崩溃,进而导致拒绝服务,或者可能在主机上以 QEMU 进程的权限执行任意代码。(CVE-2020-14364)

请注意,Nessus 尚未测试此问题,而是只依赖于应用程序自我报告的版本号。

解决方案

升级易受攻击的 CGSL qemu-kvm 程序包。请注意,可能尚无可用的已更新程序包。请联系 ZTE 获取更多信息。

另见

http://security.gd-linux.com/notice/NS-SA-2021-0004

插件详情

严重性: Medium

ID: 147408

文件名: newstart_cgsl_NS-SA-2021-0004_qemu-kvm.nasl

版本: 1.3

类型: local

发布时间: 2021/3/10

最近更新时间: 2021/3/11

依存关系: ssh_get_info.nasl

风险信息

CVSS 分数来源: CVE-2020-8608

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: Medium

基本分数: 6.8

时间分数: 5.3

矢量: AV:N/AC:M/Au:N/C:P/I:P/A:P

时间矢量: E:POC/RL:OF/RC:C

CVSS v3

风险因素: Medium

基本分数: 5.6

时间分数: 5.1

矢量: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

时间矢量: E:P/RL:O/RC:C

漏洞信息

必需的 KB 项: Host/local_checks_enabled, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list, Host/cpu

可利用: true

易利用性: Exploits are available

补丁发布日期: 2021/3/9

漏洞发布日期: 2019/7/29

参考资料信息

CVE: CVE-2019-14378, CVE-2019-15890, CVE-2020-7039, CVE-2020-8608, CVE-2020-14364