OpenSSL 1.0.2 < 1.0.2y 多个漏洞

low Nessus 插件 ID 146591
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程服务受到多种漏洞影响。

描述

远程主机上安装的测试产品版本低于测试版本。因此,该产品受到 1.0.2y 公告中提及的多个漏洞的影响。

- OpenSSL 公共 API 函数 X509_issuer_and_serial_hash() 尝试根据 X509 证书中包含的颁发者和序列号数据创建唯一哈希值。但其无法正确处理在分析颁发者字段期间可能发生的任何错误(如果颁发者字段是恶意构建的,就可能发生此类错误)。随后,这可能导致空指针取消引用和崩溃,进而可能导致拒绝服务攻击。函数 X509_issuer_and_serial_hash() 绝不会由 OpenSSL 本身直接调用,因此应用程序仅在直接使用此函数,并且在可能是从不受信任来源获得的证书上使用此函数时,才容易受到影响。OpenSSL 1.1.1i 及之前的版本受此问题影响。这些版本的用户应升级至 OpenSSL 1.1.1j。OpenSSL 1.0.2x 及之前的版本受此问题影响。但 OpenSSL 1.0.2 已不受支持,且无法再接收公共更新。OpenSSL 1.0.2 的高级支持客户应升级至 1.0.2y。其他用户应升级至 1.1.1j。已在 OpenSSL 1.1.1j 中修复(影响 1.1.1 至 1.1.1b)。已在 OpenSSL 1.0.2y 中修复(影响 1.0.2 至 1.0.2x)。(CVE-2021-23841)

- 在某些情况下,当输入长度接近平台上整数的最大允许长度时,对 EVP_CipherUpdate、EVP_EncryptUpdate 和 EVP_DecryptUpdate 的调用可能会导致输出长度参数溢出。在此类情况下,函数调用的返回值将为 1(表示成功),但输出长度值将为负。这可导致应用程序行为不正确或崩溃。
OpenSSL 1.1.1i 及之前的版本受此问题影响。这些版本的用户应升级至 OpenSSL 1.1.1j。OpenSSL 1.0.2x 及之前的版本受此问题影响。但 OpenSSL 1.0.2 已不受支持,且无法再接收公共更新。OpenSSL 1.0.2 的高级支持客户应升级至 1.0.2y。其他用户应升级至 1.1.1j。已在 OpenSSL 1.1.1j 中修复(影响 1.1.1 至 1.1.1b)。
已在 OpenSSL 1.0.2y 中修复(影响 1.0.2 至 1.0.2x)。(CVE-2021-23840)

- OpenSSL 1.0.2 支持 SSLv2。如果客户端尝试与配置为支持 SSLv2 和较新 SSL 及 TLS 版本的服务器协商 SSLv2,则在取消填充 RSA 签名时会检查版本回滚攻击。支持高于 SSLv2 的 SSL 或 TLS 版本的客户端应使用特殊填充。支持高于 SSLv2 的服务器应拒绝来自存在此特殊填充的客户端的连接尝试,因为这表明发生了版本回滚(即,客户端和服务器都支持高于 SSLv2 的版本,但现在正在请求的版本却是 SSLv2)。实施此填充检查会反转逻辑,以便在存在填充时接受连接尝试,不存在填充时拒绝连接尝试。这表示发生版本回滚攻击时,服务器将接受连接。此外,如果尝试进行正常的 SSLv2 连接,则服务器将错误地拒绝连接。只有 1.0.2s 至 1.0.2x 版本的 OpenSSL 1.0.2 服务器会受到此问题的影响。容易遭受攻击的 1.0.2 服务器具有以下特点:1) 在编译时配置了 SSLv2 支持(默认关闭),2) 在运行时配置了 SSLv2 支持(默认关闭),3) 配置了 SSLv2 加密套件(这些不在默认的加密套件列表中)OpenSSL 1.1.1 没有 SSLv2 支持,因此不易受到此问题的影响。潜在错误存在于 RSA_padding_check_SSLv23() 函数的实施中。这也会影响其他各种函数使用的 RSA_SSLV23_PADDING 填充模式。尽管 1.1.1 不支持 SSLv2,但 RSA_padding_check_SSLv23() 函数仍然存在,RSA_SSLV23_PADDING 填充模式也一样。直接调用该函数或使用该填充模式的应用程序会遇到此问题。
但由于 1.1.1 中不支持 SSLv2 协议,此问题在该版本中被视为错误而非安全问题。OpenSSL 1.0.2 已不受支持,且无法再接收公共更新。
OpenSSL 1.0.2 的高级支持客户应升级至 1.0.2y。其他用户应升级至 1.1.1j。
已在 OpenSSL 1.0.2y 中修复(影响 1.0.2s 至 1.0.2x)。(CVE-2021-23839)

请注意,Nessus 尚未测试此问题,而是只依赖于应用程序自我报告的版本号。

解决方案

升级至 OpenSSL 版本 1.0.2y 或更高版本。

另见

https://www.openssl.org/news/secadv/20210216.txt

插件详情

严重性: Low

ID: 146591

文件名: openssl_1_0_2y.nasl

版本: 1.5

类型: remote

系列: Web Servers

发布时间: 2021/2/19

最近更新时间: 2021/6/3

依存关系: openssl_version.nasl

风险信息

CVSS 分数来源: CVE-2021-23839

VPR

风险因素: Medium

分数: 6.1

CVSS v2

风险因素: Medium

基本分数: 4.3

时间分数: 3.2

矢量: AV:N/AC:M/Au:N/C:N/I:P/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Low

基本分数: 3.7

时间分数: 3.2

矢量: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:openssl:openssl

必需的 KB 项: openssl/port

易利用性: No known exploits are available

补丁发布日期: 2021/2/16

漏洞发布日期: 2021/2/16

参考资料信息

CVE: CVE-2021-23839, CVE-2021-23840, CVE-2021-23841

IAVA: 2021-A-0103-S