pfSense < 2.4.4-p3 多个漏洞

high Nessus 插件 ID 146430
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程防火墙主机受到多个漏洞影响。

描述

根据其自我报告的版本号,远程 pfSense 的安装版本低于 2.4.4-p3。因此,该应用程序受到多个漏洞的影响,其中包括:

- 在 pfSense 2.4.4_1 中,以失败的 HTTPS 身份验证阻止源 IP 地址与以 SSH 身份验证失败阻止源 IP 地址(行为与 sshguard 文档不匹配)不一致,这可能让攻击者更轻松地绕过预期访问限制。(CVE-2018-20799)

- pfSense 2.4.4_1 中的过期配置建立的区块持续时间与 sshguard 实施的区块持续时间不兼容,这可能让攻击者更轻松地绕过预期访问限制。(CVE-2018-20798)

请注意,Nessus 尚未测试这些问题,而是只依靠应用程序自我报告的版本号。

解决方案

升级到 pfSense 2.4.4-p3 或更高版本,或应用供应商公告中提及的补丁。

另见

http://www.nessus.org/u?b623e2bf

http://www.nessus.org/u?391d5f25

http://www.nessus.org/u?8a534c25

http://www.nessus.org/u?0a49b8ac

http://www.nessus.org/u?66f728f6

http://www.nessus.org/u?bb2ee7ba

http://www.nessus.org/u?0697d7a9

http://www.nessus.org/u?e41356b2

https://docs.netgate.com/pfsense/en/latest/releases/2-4-4-p3.html

插件详情

严重性: High

ID: 146430

文件名: pfsense_2_4_4_p3.nasl

版本: 1.2

类型: remote

系列: Firewalls

发布时间: 2021/2/11

最近更新时间: 2021/2/12

依存关系: pfsense_detect.nbin

风险信息

CVSS 分数来源: CVE-2018-20798

VPR

风险因素: Low

分数: 3.6

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: AV:N/AC:L/Au:N/C:N/I:P/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense, cpe:/a:netgate:pfsense

必需的 KB 项: Host/pfSense

易利用性: No known exploits are available

补丁发布日期: 2019/1/29

漏洞发布日期: 2019/1/29

参考资料信息

CVE: CVE-2018-20798, CVE-2018-20799