pfSense 2.4.x < 2.4.4-p1 多个漏洞 (SA-18_09)

high Nessus 插件 ID 146059
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程防火墙主机受到多个漏洞影响。

描述

根据其自我报告的版本号,远程 pfSense 的安装版本为低于 2.4.4-p1 的 2.4.x 版。因此,该应用程序受到多个漏洞的影响,其中包括:

- Netgate pfSense CE 2.4.4-RELEASE 处理特定 POST 请求之参数的方式中存在一个可遭利用的命令注入漏洞。攻击者可利用此漏洞在系统上执行任意命令。攻击者需要能够将认证后的 POST 请求发送至管理 Web 界面。可以在“ powerd_normal_mode”参数中注入命令。(CVE-2018-4019)

- Netgate pfSense CE 2.4.4-RELEASE 处理特定 POST 请求之参数的方式中存在一个可遭利用的命令注入漏洞。攻击者可利用此漏洞在系统上执行任意命令。攻击者需要能够将认证后的 POST 请求发送至管理 Web 界面。可以在“ powerd_ac_mode”POST 参数中注入命令。(CVE-2018-4020)

- Netgate pfSense CE 2.4.4-RELEASE 处理特定 POST 请求之参数的方式中存在一个可遭利用的命令注入漏洞。攻击者可利用此漏洞在系统上执行任意命令。攻击者需要能够将认证后的 POST 请求发送至管理 Web 界面。可以在“ powerd_battery_mode”POST 参数中注入命令。(CVE-2018-4021)

请注意,Nessus 尚未测试这些问题,而是只依靠应用程序自我报告的版本号。

解决方案

升级至 pfSense 2.4.4-p1 或更高版本,或应用供应商公告中提及的补丁程序。

另见

http://www.nessus.org/u?a654a213

https://docs.netgate.com/pfsense/en/latest/releases/2-4-4-p1.html

插件详情

严重性: High

ID: 146059

文件名: pfsense_2_4_4_p1.nasl

版本: 1.2

类型: remote

系列: Firewalls

发布时间: 2021/2/2

最近更新时间: 2021/2/3

依存关系: pfsense_detect.nbin

风险信息

CVSS 分数来源: CVE-2018-4019

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: Medium

基本分数: 6.5

时间分数: 4.8

矢量: AV:N/AC:L/Au:S/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.2

时间分数: 6.3

矢量: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense, cpe:/a:netgate:pfsense

必需的 KB 项: Host/pfSense

易利用性: No known exploits are available

补丁发布日期: 2018/11/15

漏洞发布日期: 2018/9/28

参考资料信息

CVE: CVE-2018-4019, CVE-2018-4020, CVE-2018-4021, CVE-2018-6925, CVE-2018-17154, CVE-2018-17155