IBM HTTP Server 7.0.0.0 <= 7.0.0.43 / 8.0.0.0 <= 8.0.0.14 / 8.5.0.0 < 8.5.5.14 / 9.0.0.0 < 9.0.0.8 多个漏洞 (569295)

high Nessus 插件 ID 144780
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器受到多个漏洞影响。

描述

在远程主机上运行的 IBM HTTP Server 版本受到与 Apache HTTP Server 相关的多个漏洞的影响,如下所示:

- 特制的请求可能会损坏 2.4.30 版本之前的 Apache HTTP Server,这是因为在读取 HTTP 标头达到大小限制后造成越界访问所致。视此漏洞为在非调试模式(日志和构建层级)下非常难以触发(如果并非不可能),因此针对一般服务器使用,会被分类为低风险。(CVE-2018-1301)

- 在 Apache httpd 2.0.23 到 2.0.65、2.2.0 到 2.2.34 和 2.4.0 到 2.4.29 中,如果使用 AuthLDAPCharsetConfig 配置,mod_authnz_ldap 会在验证用户的认证时,使用 Accept-Language 标头值查阅正确的字符集编码。如果字符集转换表中没有标头值,则会使用回退机制将其截断成两个字符的值,以允许快速重试(例如,'en-US' 被截断成 'en')。少于两个字符的标头值会强制将一个 NUL 字节越界写入不属于该字符串的内存位置。在最糟的情况(不太可能)下,进程崩溃会被用作拒绝服务攻击。在比较可能的情况下,此内存已保留供日后使用,因此这个问题不会造成任何影响。(CVE-2017-15710)

- 在 Apache httpd 2.4.0 到 2.4.29 中,<FilesMatch> 内指定的表达式可以将 '$' 与恶意文件名中的换行符对比,而不是只对比文件名的结尾。这可能会在外部封锁部分文件上传的环境中遭到恶意利用,但只能通过对比文件名的结尾部分。(CVE-2017-15715)

请注意,Nessus 尚未测试此问题,而是只依赖于应用程序自我报告的版本号。

解决方案

升级到 IBM HTTP Server 版本 8.5.5.14、9.0.0.8 或更高版本。或者,升级到临时补丁所需的最低 Fix Pack 级别,然后应用临时补丁 PI95670。

另见

https://www.ibm.com/support/pages/node/569295

插件详情

严重性: High

ID: 144780

文件名: ibm_http_server_569295.nasl

版本: 1.3

类型: local

代理: unix

系列: Web Servers

发布时间: 2021/1/6

最近更新时间: 2021/1/25

依存关系: ibm_http_server_nix_installed.nbin

风险信息

CVSS 分数来源: CVE-2017-15715

VPR

风险因素: High

分数: 7.4

CVSS v2

风险因素: Medium

基本分数: 6.8

时间分数: 5

矢量: AV:N/AC:M/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 8.1

时间分数: 7.1

矢量: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:ibm:http_server

必需的 KB 项: installed_sw/IBM HTTP Server (IHS)

易利用性: No known exploits are available

补丁发布日期: 2020/4/11

漏洞发布日期: 2020/3/26

参考资料信息

CVE: CVE-2017-15710, CVE-2017-15715, CVE-2018-1301

BID: 103512, 103515, 103525