phpMyAdmin 4.0.x < 4.0.10.18 / 4.4.x < 4.4.15.9 / 4.6.x < 4.6.5 多个漏洞

critical Nessus 插件 ID 143532
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器托管的一个 PHP 应用程序受到多个漏洞的影响。

描述

根据其自我报告的版本,远程 Web 服务器上托管的 phpMyAdmin 应用程序为低于 4.0.10.18 的 4.0.x、低于 4.4.15.9 的 4.4.x 或低于 4.6.5 的 4.6.x。因此,该应用程序受到多个漏洞的影响。

- 在 phpMyAdmin 中发现一个问题。当用户未指定用于加密 Cookie 的 blowfish_secret 密钥时,phpMyAdmin 会在运行时生成一个密钥。据报告,存在一个漏洞,即创建此值的方式为使用弱算法。攻击者可利用此漏洞确定用户的 blowfish_secret,并可能解密其 Cookie。所有 4.6.x 版本(4.6.5 之前)、4.4.x 版本(4.4.15.9 之前)和 4.0.x 版本(4.0.10.18 之前)均受影响。(CVE-2016-9847)

- 在 phpMyAdmin 中发现一个问题。phpinfo (phpinfo.php) 会显示 PHP 信息,其中包括 HttpOnly Cookie 的值。所有 4.6.x 版本(4.6.5 之前)、4.4.x 版本(4.4.15.9 之前)和 4.0.x 版本(4.0.10.18 之前)均受影响。(CVE-2016-9848)

- 在 phpMyAdmin 中发现一个问题。可以通过在用户名中使用空字节来绕过 AllowRoot 限制 ($cfg['Servers'][$i]['AllowRoot']) 并拒绝用户名规则。所有 4.6.x 版本(4.6.5 之前)、4.4.x 版本(4.4.15.9 之前)和 4.0.x 版本(4.0.10.18 之前)均受影响。(CVE-2016-9849)

- 在 phpMyAdmin 中发现一个问题。由于执行时间不恒定,允许/拒绝规则的用户名匹配可能会导致匹配错误并在规则中检测到用户名。所有 4.6.x 版本(4.6.5 之前)、4.4.x 版本(4.4.15.9 之前)和 4.0.x 版本(4.0.10.18 之前)均受影响。(CVE-2016-9850)

- 在 phpMyAdmin 中发现一个问题。通过构建的请求参数值,可以绕过注销超时。所有 4.6.x 版本(4.6.5 之前)和 4.4.x 版本(4.4.15.9 之前)均受影响。
(CVE-2016-9851)

- 在 phpMyAdmin 中发现一个问题。通过以意外的方式调用 phpMyAdmin 的部分脚本,有可能触发 phpMyAdmin,从而显示 PHP 错误消息,其中包含 phpMyAdmin 安装目录所在的完整路径。在导出功能执行超时期间,包含 phpMyAdmin 目录完整路径的错误会写入导出文件。所有 4.6.x 版本(4.6.5 之前)和 4.4.x 版本(4.4.15.9 之前)均受影响。
此 CVE 适用于 curl 封装程序问题。(CVE-2016-9852)

- 在 phpMyAdmin 中发现一个问题。通过以意外的方式调用 phpMyAdmin 的部分脚本,有可能触发 phpMyAdmin,从而显示 PHP 错误消息,其中包含 phpMyAdmin 安装目录所在的完整路径。在导出功能执行超时期间,包含 phpMyAdmin 目录完整路径的错误会写入导出文件。所有 4.6.x 版本(4.6.5 之前)和 4.4.x 版本(4.4.15.9 之前)均受影响。
此 CVE 适用于 fopen 封装程序问题。(CVE-2016-9853)

- 在 phpMyAdmin 中发现一个问题。通过以意外的方式调用 phpMyAdmin 的部分脚本,有可能触发 phpMyAdmin,从而显示 PHP 错误消息,其中包含 phpMyAdmin 安装目录所在的完整路径。在导出功能执行超时期间,包含 phpMyAdmin 目录完整路径的错误会写入导出文件。所有 4.6.x 版本(4.6.5 之前)和 4.4.x 版本(4.4.15.9 之前)均受影响。
此 CVE 适用于 json_decode 问题。 (CVE-2016-9854)

- 在 phpMyAdmin 中发现一个问题。通过以意外的方式调用 phpMyAdmin 的部分脚本,有可能触发 phpMyAdmin,从而显示 PHP 错误消息,其中包含 phpMyAdmin 安装目录所在的完整路径。在导出功能执行超时期间,包含 phpMyAdmin 目录完整路径的错误会写入导出文件。所有 4.6.x 版本(4.6.5 之前)和 4.4.x 版本(4.4.15.9 之前)均受影响。
此 CVE 适用于 PMA_shutdownDuringExport 问题。(CVE-2016-9855)

- 在 phpMyAdmin 中发现一个 XSS 问题,这是为正确修复 PMASA-2016-10 中的 CVE-2016-2559 所致。
已通过使用哈希副本避免争用条件的方式解决此问题。所有 4.6.x 版本(4.6.5 之前)、4.4.x 版本(4.4.15.9 之前)和 4.0.x 版本(4.0.10.18 之前)均受影响。
(CVE-2016-9856)

- 在 phpMyAdmin 中发现一个问题。由于在某些 JavaScript 处理中使用的正则表达式存在漏洞,可能导致 XSS。所有 4.6.x 版本(4.6.5 之前)、4.4.x 版本(4.4.15.9 之前)和 4.0.x 版本(4.0.10.18 之前)均受影响。(CVE-2016-9857)

- 在 phpMyAdmin 中发现一个问题。通过构建的请求参数值,可以在保存的搜索功能中发起拒绝服务攻击。所有 4.6.x 版本(4.6.5 之前)、4.4.x 版本(4.4.15.9 之前)和 4.0.x 版本(4.0.10.18 之前)均受影响。(CVE-2016-9858)

- 在 phpMyAdmin 中发现一个问题。通过构建的请求参数值,可以在导入功能中发起拒绝服务攻击。所有 4.6.x 版本(4.6.5 之前)、4.4.x 版本(4.4.15.9 之前)和 4.0.x 版本(4.0.10.18 之前)均受影响。(CVE-2016-9859)

- 在 phpMyAdmin 中发现一个问题。未经身份验证的用户可在 phpMyAdmin 以 $cfg['AllowArbitraryServer']=true 的条件运行时执行拒绝服务攻击。所有 4.6.x 版本(4.6.5 之前)、4.4.x 版本(4.4.15.9 之前)和 4.0.x 版本(4.0.10.18 之前)均受影响。(CVE-2016-9860)

- 在 phpMyAdmin 中发现一个问题。由于 URL 匹配的限制,可以绕过 URL 白名单保护。所有 4.6.x 版本(4.6.5 之前)、4.4.x 版本(4.4.15.9 之前)和 4.0.x 版本(4.0.10.18 之前)均受影响。(CVE-2016-9861)

- 在 phpMyAdmin 中发现一个问题。可以通过构建的登录请求在登录页面注入 BBCode。所有 4.6.x 版本(4.6.5 之前)均受影响。(CVE-2016-9862)

- 在 phpMyAdmin 中发现一个问题。如果对表分区函数存有极大请求,便可发起拒绝服务 (DoS) 攻击。所有 4.6.x 版本(4.6.5 之前)均受影响。
(CVE-2016-9863)

- 在 phpMyAdmin 中发现一个问题。通过构建的用户名或表格名称,可以在跟踪功能中注入 SQL 语句,这些语句将以控制用户的权限运行。这样就可以对配置存储数据库的表格进行读写访问,如果控制用户具有必要权限,还可以对 MySQL 数据库的一些表格进行读写访问。所有 4.6.x 版本(4.6.5 之前)、4.4.x 版本(4.4.15.9 之前)和 4.0.x 版本(4.0.10.18 之前)均受影响。
(CVE-2016-9864)

- 在 phpMyAdmin 中发现一个问题。由于序列化字符串解析中的错误,可以绕过 PMA_safeUnserialize() 函数提供的保护。所有 4.6.x 版本(4.6.5 之前)、4.4.x 版本(4.4.15.9 之前)和 4.0.x 版本(4.0.10.18 之前)均受影响。(CVE-2016-9865)

- 在 phpMyAdmin 中发现一个问题。如果 arg_separator 与其默认的 & 值不同,则表明 CSRF 标记未正确从首选项导入操作的返回 URL 中剥离。所有 4.6.x 版本(4.6.5 之前)、4.4.x 版本(4.4.15.9 之前)和 4.0.x 版本(4.0.10.18 之前)均受影响。(CVE-2016-9866)

请注意,Nessus 尚未测试此问题,而是只依赖于应用程序自我报告的版本号。

解决方案

升级版本到 phpMyAdmin 4.0.10.18 / 4.4.15.9 / 4.6.5 或更高版本。

另见

https://www.phpmyadmin.net/security/PMASA-2016-58/

https://www.phpmyadmin.net/security/PMASA-2016-59/

https://www.phpmyadmin.net/security/PMASA-2016-60/

https://www.phpmyadmin.net/security/PMASA-2016-61/

https://www.phpmyadmin.net/security/PMASA-2016-62/

https://www.phpmyadmin.net/security/PMASA-2016-63/

https://www.phpmyadmin.net/security/PMASA-2016-64/

https://www.phpmyadmin.net/security/PMASA-2016-65/

https://www.phpmyadmin.net/security/PMASA-2016-66/

https://www.phpmyadmin.net/security/PMASA-2016-67/

https://www.phpmyadmin.net/security/PMASA-2016-68/

https://www.phpmyadmin.net/security/PMASA-2016-69/

https://www.phpmyadmin.net/security/PMASA-2016-70/

https://www.phpmyadmin.net/security/PMASA-2016-71/

插件详情

严重性: Critical

ID: 143532

文件名: phpmyadmin_pmasa_4_6_5.nasl

版本: 1.4

类型: remote

系列: CGI abuses

发布时间: 2020/12/7

最近更新时间: 2020/12/21

依存关系: phpMyAdmin_detect.nasl

配置: 启用偏执模式

风险信息

CVSS 分数来源: CVE-2016-9865

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.5

矢量: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: CVSS2#E:U/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

漏洞信息

CPE: cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:*

必需的 KB 项: www/PHP, Settings/ParanoidReport, installed_sw/phpMyAdmin

易利用性: No known exploits are available

补丁发布日期: 2016/11/25

漏洞发布日期: 2016/11/25

参考资料信息

CVE: CVE-2016-9847, CVE-2016-9848, CVE-2016-9849, CVE-2016-9850, CVE-2016-9851, CVE-2016-9852, CVE-2016-9853, CVE-2016-9854, CVE-2016-9855, CVE-2016-9856, CVE-2016-9857, CVE-2016-9858, CVE-2016-9859, CVE-2016-9860, CVE-2016-9861, CVE-2016-9862, CVE-2016-9863, CVE-2016-9864, CVE-2016-9865, CVE-2016-9866

BID: 94521, 94529, 94535, 94533, 94527, 94531, 94524, 94523, 94534, 94530, 94525, 94536, 94526, 94528

CWE: 20, 89, 352, 601, 400, 661