phpMyAdmin 4.0.0 < 4.0.10.17 / 4.4.0 < 4.4.15.8 / 4.6.0 < 4.6.4 多个漏洞

critical Nessus 插件 ID 143282
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器托管的一个 PHP 应用程序受到多个漏洞的影响。

描述

根据其自我报告的版本,远程 Web 服务器上托管的 phpMyAdmin 应用程序为低于 4.0.10.17 的 4.0.x、低于 4.4.15.8 的 4.4.x 或低于 4.6.4 的 4.6.x。因此,该应用程序受到多个漏洞的影响。

- 在 phpMyAdmin 的 Cookie 加密中发现一个问题。用户名/密码解密容易受到 padding oracle 攻击。这可允许能够访问用户浏览器 Cookie 文件的攻击者解密用户名与密码。此外,相同的初始化矢量 (IV) 用于哈希存储在 phpMyAdmin cookie 中的用户名和密码。如果用户所用的密码与用户名相同,则检查浏览器 Cookie 的攻击者即可其为相同 - 但由于 Cookie 仍受哈希处理,因此无法直接从 Cookie 解密这些值。所有 4.6.x 版本(4.6.4 之前)、4.4.x 版本(4.4.15.8 之前)和 4.0.x 版本(4.0.10.17 之前)均受影响。(CVE-2016-6606)

- 在 phpMyAdmin 中发现 XSS 问题。这会影响缩放搜索(可用于触发 XSS 攻击的特别构建的列内容);GIS 编辑器(图形 GIS 编辑器中的某些字段未正确转义,且可用于触发 XSS 攻击);关系视图;以下转换:
格式化、图像链接、JPEG:上传、RegexValidation、JPEG 内联、PNG 内联和转换封装程序;
XML 导出;MediaWiki 导出;Designer;当 MySQL 服务器以特别构建的 log_bin 指令运行时;Database 选项卡;复制功能;和数据库搜索。所有 4.6.x 版本(4.6.4 之前)、4.4.x 版本(4.4.15.8 之前)和 4.0.x 版本(4.0.10.17 之前)均受影响。(CVE-2016-6607)

- 在 phpMyAdmin 中发现 XSS 问题。这会影响数据库特权检查和删除分区功能。特别构建的数据库名称可触发 XSS 攻击。所有 4.6.x 版本(4.6.4 之前)均受影响。(CVE-2016-6608)

- 在 phpMyAdmin 中发现一个问题。特别构建的数据库名称可用来通过数组导出功能运行任意 PHP 命令。所有 4.6.x 版本(4.6.4 之前)、4.4.x 版本(4.4.15.8 之前)和 4.0.x 版本(4.0.10.17 之前)均受影响。(CVE-2016-6609)

- 在 phpMyAdmin 中发现一个完整路径泄露漏洞,其允许用户在导出机制中触发特定错误,以发现磁盘中 phpMyAdmin 的完整路径。所有 4.6.x 版本(4.6.4 之前)、4.4.x 版本(4.4.15.8 之前)和 4.0.x 版本(4.0.10.17 之前)均受影响。(CVE-2016-6610)

- 在 phpMyAdmin 中发现一个问题。特别构建的数据库和/或表名称可用来通过导出功能触发 SQL 注入攻击。所有 4.6.x 版本(4.6.4 之前)、4.4.x 版本(4.4.15.8 之前)和 4.0.x 版本(4.0.10.17 之前)均受影响。(CVE-2016-6611)

- 在 phpMyAdmin 中发现一个问题。用户可利用 LOAD LOCAL INFILE 功能来将服务器上的文件泄露给数据库系统。所有 4.6.x 版本(4.6.4 之前)、4.4.x 版本(4.4.15.8 之前)和 4.0.x 版本(4.0.10.17 之前)均受影响。(CVE-2016-6612)

- 在 phpMyAdmin 中发现一个问题。用户可在在磁盘上特别构建一个符号链接,其针对 phpMyAdmin 可读取但用户无法读取的文件,而随后 phpMyAdmin 会将该文件泄露给用户。所有 4.6.x 版本(4.6.4 之前)、4.4.x 版本(4.4.15.8 之前)和 4.0.x 版本(4.0.10.17 之前)均受影响。(CVE-2016-6613)

- 在 phpMyAdmin 中发现一个问题,该问题涉及 SaveDir 和 UploadDir 功能的 %u 用户名替换功能。配置替代用户名时,可使用特别构建的用户名来避开遍历文件系统的限制。所有 4.6.x 版本(4.6.4 之前)、4.4.x 版本(4.4.15.8 之前)和 4.0.x 版本(4.0.10.17 之前)均受影响。(CVE-2016-6614)

- 在 phpMyAdmin 中发现 XSS 问题。这会影响导航窗格和数据库/表隐藏功能(可使用特别构建的数据库名称触发 XSS 攻击);跟踪功能(可使用特别构建的查询触发 XSS 攻击);和 GIS 可视化功能。所有 4.6.x 版本(4.6.4 之前)和 4.4.x 版本(4.4.15.8 之前)均受影响。(CVE-2016-6615)

- 在 phpMyAdmin 中发现一个问题。在用户群组和设计者功能中,用户可针对控件用户的帐户执行 SQL 注入攻击。所有 4.6.x 版本(4.6.4 之前)和 4.4.x 版本(4.4.15.8 之前)均受影响。(CVE-2016-6616)

- 在 phpMyAdmin 中发现一个问题。特别构建的数据库和/或表名称可用来通过导出功能触发 SQL 注入攻击。所有 4.6.x 版本(4.6.4 之前)均受影响。(CVE-2016-6617)

- 在 phpMyAdmin 中发现一个问题。转换功能允许用户触发针对服务器的拒绝服务 (DoS) 攻击。所有 4.6.x 版本(4.6.4 之前)、4.4.x 版本(4.4.15.8 之前)和 4.0.x 版本(4.0.10.17 之前)均受影响。(CVE-2016-6618)

- 在 phpMyAdmin 中发现一个问题。在用户界面首选项功能中,用户可针对控件用户的帐户执行 SQL 注入攻击。所有 4.6.x 版本(4.6.4 之前)、4.4.x 版本(4.4.15.8 之前)和 4.0.x 版本(4.0.10.17 之前)均受影响。(CVE-2016-6619)

- 在 phpMyAdmin 中发现一个问题。一些数据未经验证为有效的序列化数据,即传递到 PHP unserialize() 函数。反序列化可导致代码执行,这是与对象实例化和自动加载的交互所致。所有 4.6.x 版本(4.6.4 之前)、4.4.x 版本(4.4.15.8 之前)和 4.0.x 版本(4.0.10.17 之前)均受影响。(CVE-2016-6620)

- 在 phpMyAdmin 中发现一个问题。未经身份认证的用户可通过在 $cfg['AllowArbitraryServer']=true 的情况下运行 phpMyAdmin 时强制持续连接,来执行拒绝服务 (DoS) 攻击。所有 4.6.x 版本(4.6.4 之前)、4.4.x 版本(4.4.15.8 之前)和 4.0.x 版本(4.0.10.17 之前)均受影响。(CVE-2016-6622)

- 在 phpMyAdmin 中发现一个问题。授权用户可通过将大值传送给循环来对服务器造成拒绝服务 (DoS) 攻击。所有 4.6.x 版本(4.6.4 之前)、4.4.x 版本(4.4.15.8 之前)和 4.0.x 版本(4.0.10.17 之前)均受影响。(CVE-2016-6623)

- 在 phpMyAdmin 中发现一个问题,该问题涉及未正确强制执行基于 IP 的身份验证规则。
当 phpMyAdmin 在代理服务器环境中与 IPv6 搭配使用,且代理服务器处于允许的范围内,但不允许存在攻击性计算机时,此漏洞可允许攻击性计算机进行连接,而不管 IP 规则如何。所有 4.6.x 版本(4.6.4 之前)、4.4.x 版本(4.4.15.8 之前)和 4.0.x 版本(4.0.10.17 之前)均受影响。(CVE-2016-6624)

- 在 phpMyAdmin 中发现一个问题。攻击者可以判断用户是否已登录 phpMyAdmin。用户的会话、用户名和密码都不会因此漏洞而遭到破坏。所有 4.6.x 版本(4.6.4 之前)、4.4.x 版本(4.4.15.8 之前)和 4.0.x 版本(4.0.10.17 之前)均受影响。(CVE-2016-6625)

- 在 phpMyAdmin 中发现一个问题。攻击者可将用户重定向到恶意网页。所有 4.6.x 版本(4.6.4 之前)、4.4.x 版本(4.4.15.8 之前)和 4.0.x 版本(4.0.10.17 之前)均受影响。(CVE-2016-6626)

- 在 phpMyAdmin 中发现一个问题。攻击者可通过文件 url.php 确定 phpMyAdmin 主机位置。所有 4.6.x 版本(4.6.4 之前)、4.4.x 版本(4.4.15.8 之前)和 4.0.x 版本(4.0.10.17 之前)均受影响。(CVE-2016-6627)

- 在 phpMyAdmin 中发现一个问题。攻击者可能可以触发用户下载特别构建的恶意 SVG 文件。所有 4.6.x 版本(4.6.4 之前)、4.4.x 版本(4.4.15.8 之前)和 4.0.x 版本(4.0.10.17 之前)均受影响。(CVE-2016-6628)

- 在 phpMyAdmin 中发现涉及 $cfg['ArbitraryServerRegexp'] 配置指令的问题。
攻击者可以绕过 ArbitraryServerRegexp 定义的服务器的方式重复使用某些 cookie 值。所有 4.6.x 版本(4.6.4 之前)、4.4.x 版本(4.4.15.8 之前)和 4.0.x 版本(4.0.10.17 之前)均受影响。(CVE-2016-6629)

- 在 phpMyAdmin 中发现一个问题。经认证的用户可通过在变更密码对话框中输入非常长的密码来触发拒绝服务 (DoS) 攻击。所有 4.6.x 版本(4.6.4 之前)、4.4.x 版本(4.4.15.8 之前)和 4.0.x 版本(4.0.10.17 之前)均受影响。(CVE-2016-6630)

- 在 phpMyAdmin 中发现一个问题。用户可以在 phpMyAdmin 作为 CGI 应用程序运行时,对服务器执行远程代码执行攻击。在某些服务器配置下,用户可传递由 generator_plugin.sh 文件作为命令行参数执行的查询字符串。所有 4.6.x 版本(4.6.4 之前)、4.4.x 版本(4.4.15.8 之前)和 4.0.x 版本(4.0.10.17 之前)均受影响。(CVE-2016-6631)

- 在 phpMyAdmin 中发现了一个问题,在某些情况下,phpMyAdmin 可能不会在导入 ESRI 文件期间删除临时文件。所有 4.6.x 版本(4.6.4 之前)、4.4.x 版本(4.4.15.8 之前)和 4.0.x 版本(4.0.10.17 之前)均受影响。(CVE-2016-6632)

- 在 phpMyAdmin 中发现了一个问题。 phpMyAdmin 可用于触发对以 dbase 扩展运行的某些 PHP 安装的远程代码执行攻击。所有 4.6.x 版本(4.6.4 之前)、4.4.x 版本(4.4.15.8 之前)和 4.0.x 版本(4.0.10.17 之前)均受影响。
(CVE-2016-6633)

请注意,Nessus 尚未测试此问题,而是只依赖于应用程序自我报告的版本号。

解决方案

升级版本到 phpMyAdmin 4.0.10.17 / 4.4.15.8 / 4.6.4 或更高版本。

另见

https://www.phpmyadmin.net/security/PMASA-2016-29/

https://www.phpmyadmin.net/security/PMASA-2016-30/

https://www.phpmyadmin.net/security/PMASA-2016-31/

https://www.phpmyadmin.net/security/PMASA-2016-32/

https://www.phpmyadmin.net/security/PMASA-2016-33/

https://www.phpmyadmin.net/security/PMASA-2016-34/

https://www.phpmyadmin.net/security/PMASA-2016-35/

https://www.phpmyadmin.net/security/PMASA-2016-36/

https://www.phpmyadmin.net/security/PMASA-2016-37/

https://www.phpmyadmin.net/security/PMASA-2016-38/

https://www.phpmyadmin.net/security/PMASA-2016-39/

https://www.phpmyadmin.net/security/PMASA-2016-40/

https://www.phpmyadmin.net/security/PMASA-2016-41/

https://www.phpmyadmin.net/security/PMASA-2016-42/

https://www.phpmyadmin.net/security/PMASA-2016-43/

https://www.phpmyadmin.net/security/PMASA-2016-45/

https://www.phpmyadmin.net/security/PMASA-2016-46/

https://www.phpmyadmin.net/security/PMASA-2016-47/

https://www.phpmyadmin.net/security/PMASA-2016-48/

https://www.phpmyadmin.net/security/PMASA-2016-49/

https://www.phpmyadmin.net/security/PMASA-2016-50/

https://www.phpmyadmin.net/security/PMASA-2016-51/

https://www.phpmyadmin.net/security/PMASA-2016-52/

https://www.phpmyadmin.net/security/PMASA-2016-53/

https://www.phpmyadmin.net/security/PMASA-2016-54/

https://www.phpmyadmin.net/security/PMASA-2016-55/

https://www.phpmyadmin.net/security/PMASA-2016-56/

插件详情

严重性: Critical

ID: 143282

文件名: phpmyadmin_pmasa_4_6_4.nasl

版本: 1.3

类型: remote

系列: CGI abuses

发布时间: 2020/11/30

最近更新时间: 2020/12/1

依存关系: phpMyAdmin_detect.nasl

配置: 启用偏执模式

风险信息

CVSS 分数来源: CVE-2016-6629

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: Critical

基本分数: 10

时间分数: 7.4

矢量: AV:N/AC:L/Au:N/C:C/I:C/A:C

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:phpmyadmin:phpmyadmin

必需的 KB 项: www/PHP, installed_sw/phpMyAdmin, Settings/ParanoidReport

易利用性: No known exploits are available

补丁发布日期: 2016/8/16

漏洞发布日期: 2016/7/7

参考资料信息

CVE: CVE-2016-6606, CVE-2016-6607, CVE-2016-6608, CVE-2016-6609, CVE-2016-6610, CVE-2016-6611, CVE-2016-6612, CVE-2016-6613, CVE-2016-6614, CVE-2016-6615, CVE-2016-6616, CVE-2016-6617, CVE-2016-6618, CVE-2016-6619, CVE-2016-6620, CVE-2016-6622, CVE-2016-6623, CVE-2016-6624, CVE-2016-6625, CVE-2016-6626, CVE-2016-6627, CVE-2016-6628, CVE-2016-6629, CVE-2016-6630, CVE-2016-6631, CVE-2016-6632, CVE-2016-6633

BID: 92489, 92490, 92491, 92492, 92493, 92494, 92496, 92497, 92500, 92501, 93257, 93258, 94112, 94113, 94114, 94115, 94117, 94118, 94366, 95041, 95042, 95044, 95047, 95048, 95049, 95052, 95055

CWE: 661