Amazon Linux AMI:json-c (ALAS-2020-1381)

high Nessus 插件 ID 138054

简介

The remote Amazon Linux AMI host is missing a security update.

描述

在 json-c 0.14 及之前的版本中,存在整数溢出和通过较大的 JSON 文件造成的越界写入漏洞,printbuf_memappend 即为一例。
(CVE-2020-12762)

解决方案

Run 'yum update json-c' to update your system.

另见

https://alas.aws.amazon.com/ALAS-2020-1381.html

插件详情

严重性: High

ID: 138054

文件名: ala_ALAS-2020-1381.nasl

版本: 1.2

类型: local

代理: unix

发布时间: 2020/7/2

最近更新时间: 2020/7/6

支持的传感器: Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent

风险信息

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: Medium

基本分数: 6.8

时间分数: 5

矢量: AV:N/AC:M/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.8

时间分数: 6.8

矢量: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:amazon:linux:json-c, p-cpe:/a:amazon:linux:json-c-debuginfo, p-cpe:/a:amazon:linux:json-c-devel, p-cpe:/a:amazon:linux:json-c-doc, cpe:/o:amazon:linux

必需的 KB 项: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

易利用性: No known exploits are available

补丁发布日期: 2020/6/26

漏洞发布日期: 2020/5/9

参考资料信息

CVE: CVE-2020-12762

ALAS: 2020-1381