PHP 7.2.x < 7.2.26 多个漏洞

high Nessus 插件 ID 132770

简介

远程 Web 服务器上运行的 PHP 版本受到多个漏洞的影响。

描述

据其标题,远程 Web 服务器上运行的 PHP 版本为低于 7.2.26 的 7.2.x。因而易受多个漏洞的影响:- 链接 () 和目录迭代器类中存在任意文件读取漏洞,这是由于未正确处理嵌入的 \0 字节字符,并将他们视为在该字节处终止。攻击者可以利用这一点,在允许代码访问的应用程序检查路径中泄露信息。(CVE-2019-11044 CVE-2019-11045) - 由于输入验证错误,bcmath 扩展中存在越界读取错误。未经身份验证的远程攻击者可以通过提供包含字符的字符串利用这一点,该字符串被操作系统识别为数值,但其并非 ASCII 数字。这可导致某些内存位置内的信息泄露。(CVE-2019-11046) - 在从图像解析 EXIF 信息时,存在越界读取错误。未经身份验证的远程攻击者可以利用这一点,并向其提供数据,使其读取超过分配的信息公开缓冲区的数据。(CVE-2019-11047)

解决方案

升级至 PHP 版本 7.2.26 或更高版本。

另见

http://php.net/ChangeLog-7.php#7.2.26

插件详情

严重性: High

ID: 132770

文件名: php_7_2_26.nasl

版本: 1.6

类型: remote

系列: CGI abuses

发布时间: 2020/1/10

最近更新时间: 2022/5/18

配置: 启用偏执模式, 启用彻底检查

风险信息

VPR

风险因素: Medium

分数: 4.4

CVSS v2

风险因素: Medium

基本分数: 6.4

时间分数: 4.7

矢量: AV:N/AC:L/Au:N/C:P/I:N/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2019-11050

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

时间矢量: E:U/RL:O/RC:C

CVSS 分数来源: CVE-2019-11046

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP, installed_sw/PHP, Settings/ParanoidReport

易利用性: No known exploits are available

补丁发布日期: 2019/12/18

漏洞发布日期: 2019/12/18

参考资料信息

CVE: CVE-2019-11044, CVE-2019-11045, CVE-2019-11046, CVE-2019-11047, CVE-2019-11050