NewStart CGSL MAIN 4.06:java-1.8.0-openjdk 多个漏洞 (NS-SA-2019-0178)

medium Nessus 插件 ID 128697

语言:

简介

远程机器受到多个漏洞影响。

描述

运行版本 MAIN 4.06 的远程 NewStart CGSL 主机拥安装有受多个漏洞影响的 java-1.8.0-openjdk 程序包:- Oracle Java SE 的 Java SE 组件中的漏洞(子组件:JCE)。支持的受影响版本为 Java SE: 8u212。难以利用的漏洞允许未经身份验证的攻击者通过多种协议进行网络访问,从而危害 Java SE。成功攻击此漏洞可导致在未经授权的情况下造成 Java SE 部分拒绝服务(部分 DOS)。注意:此漏洞适用于需加载并运行不可信代码(如来自互联网的代码)且安全性依赖于 Java 沙盒的 Java 部署,该部署通常在沙盒式 Java Web Start 应用程序或沙盒式 Java 小程序(在 Java SE 8 中)的客户端上。此漏洞也可通过使用指定组件中的 API 加以利用,如通过向 API 提供数据的 Web 服务。CVSS 3.0 基本分数 3.7(可用性影响)。CVSS 向量:(CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L)。(CVE-2019-2842) - Oracle Java SE 的 Java SE 组件中的漏洞(子组件:Security)。支持的版本中受影响的是 Java SE:7u221、8u212 和 11.0.3。难以利用的漏洞允许未经身份验证的攻击者登录 Java SE 执行的基础结构,从而破坏 Java SE。成功攻击此漏洞可导致在未经授权的情况下访问重要数据,或完整访问所有可供访问的 Java SE 数据。注意:此漏洞适用于需加载并运行不可信代码(如来自互联网的代码)且安全性依赖于 Java 沙盒的 Java 部署,该部署通常在沙盒式 Java Web Start 应用程序或沙盒式 Java 小程序(在 Java SE 8 中)的客户端上。此漏洞也可通过使用指定组件中的 API 加以利用,如通过向 API 提供数据的 Web 服务。CVSS 3.0 基本分数 5.1(机密性影响)。CVSS 向量:(CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N)。(CVE-2019-2745) - Oracle Java SE 的 Java SE、Java SE Embedded 组件中的漏洞(子组件:实用工具)。支持的版本中受影响的是 Java SE:7u221、8u212、11.0.3 和 12.0.1;Java SE Embedded:8u211。可轻松利用的漏洞允许未经身份验证的攻击者通过多种协议进行网络访问,从而破坏 Java SE、Java SE Embedded。成功攻击此漏洞可导致在未经授权的情况下造成 Java SE、Java SE Embedded 部分拒绝服务(部分 DOS)。注意:此漏洞适用于需加载并运行不可信代码(如来自互联网的代码)且安全性依赖于 Java 沙盒的 Java 部署,该部署通常在沙盒式 Java Web Start 应用程序或沙盒式 Java 小程序(在 Java SE 8 中)的客户端上。此漏洞也可通过使用指定组件中的 API 加以利用,如通过向 API 提供数据的 Web 服务。CVSS 3.0 基本分数 5.3(可用性影响)。CVSS 向量:(CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L)。(CVE-2019-2762, CVE-2019-2769) - Oracle Java SE 的 Java SE、Java SE Embedded 组件中的漏洞(子组件:Networking)。支持的版本中受影响的是 Java SE:7u221、8u212、11.0.3 和 12.0.1;Java SE Embedded:8u211。难以利用的漏洞允许未经身份验证的攻击者通过多种协议进行网络访问,从而破坏 Java SE、Java SE Embedded。成功攻击此漏洞可导致在未经授权的情况下更新、插入或删除某些 Java SE、Java SE Embedded 可访问数据的访问权限,以及对 Java SE、Java SE Embedded 可访问数据子集进行未经授权的读取访问。注意:此漏洞适用于需加载并运行不可信代码(如来自互联网的代码)且安全性依赖于 Java 沙盒的 Java 部署,该部署通常在沙盒式 Java Web Start 应用程序或沙盒式 Java 小程序(在 Java SE 8 中)的客户端上。此漏洞也可通过使用指定组件中的 API 加以利用,如通过向 API 提供数据的 Web 服务。CVSS 3.0 基本分数 4.8(机密性和完整性影响)。CVSS 向量:(CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N)。(CVE-2019-2816) - Oracle Java SE 的 Java SE、Java SE Embedded 组件中的漏洞(子组件:Security)。支持的版本中受影响的是 Java SE:8u212、11.0.3 和 12.0.1;Java SE Embedded:8u211。难以利用的漏洞允许未经身份验证的攻击者通过多种协议进行网络访问,从而破坏 Java SE、Java SE Embedded。除攻击者以外的他人进行交互是实现成功攻击的必要条件,尽管漏洞存在于 Java SE、Java SE Embedded 中,但攻击也可能会严重影响其他产品。成功攻击此漏洞可导致对 Java SE、Java SE Embedded 可访问数据子集进行未经授权的读取访问。注意:此漏洞适用于需加载并运行不可信代码(如来自互联网的代码)且安全性依赖于 Java 沙盒的 Java 部署,该部署通常在沙盒式 Java Web Start 应用程序或沙盒式 Java 小程序(在 Java SE 8 中)的客户端上。此漏洞也可通过使用指定组件中的 API 加以利用,如通过向 API 提供数据的 Web 服务。CVSS 3.0 基本分数 3.4(机密性影响)。CVSS 向量:(CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N)。(CVE-2019-2786) 请注意,Nessus 并未针对此问题进行测试,而仅依赖应用程序自我报告的版本号。

解决方案

更新易受攻击的 CGSL java-1.8.0-openjdk 程序包。请注意,可能尚无可用的已更新程序包。请联系 ZTE 获取更多信息。

另见

http://security.gd-linux.com/notice/NS-SA-2019-0178

插件详情

严重性: Medium

ID: 128697

文件名: newstart_cgsl_NS-SA-2019-0178_java-1.8.0-openjdk.nasl

版本: 1.10

类型: local

发布时间: 2019/9/11

最近更新时间: 2022/5/19

风险信息

VPR

风险因素: Medium

分数: 4.4

CVSS v2

风险因素: Medium

基本分数: 5.8

时间分数: 4.3

矢量: AV:N/AC:M/Au:N/C:P/I:P/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2019-2816

CVSS v3

风险因素: Medium

基本分数: 5.1

时间分数: 4.5

矢量: CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

时间矢量: E:U/RL:O/RC:C

CVSS 分数来源: CVE-2019-2745

漏洞信息

必需的 KB 项: Host/local_checks_enabled, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list, Host/cpu

易利用性: No known exploits are available

补丁发布日期: 2019/8/29

漏洞发布日期: 2019/7/23

参考资料信息

CVE: CVE-2019-2745, CVE-2019-2762, CVE-2019-2769, CVE-2019-2786, CVE-2019-2816, CVE-2019-2842