Oracle WebLogic WLS9-async 远程代码执行(远程检查)

critical Nessus 插件 ID 124338

简介

远程 Oracle WebLogic 服务器受到一个远程代码执行漏洞的影响。

描述

由于 XML 编码 Java 对象的不安全反序列化,远程 Oracle WebLogic 服务器受到 WLS9-async 组件中远程代码执行漏洞的影响。未经身份验证的远程攻击者可利用此问题,通过构建的 Java 对象,在 WebLogic 服务器环境中执行任意 Java 代码。

解决方案

应用供应商公告提到的修补程序。

另见

http://www.nessus.org/u?a0f63bc8

http://www.nessus.org/u?72a7d15c

http://www.cnvd.org.cn/webinfo/show/4989

插件详情

严重性: Critical

ID: 124338

文件名: weblogic_async_response_rce.nbin

版本: 1.37

类型: remote

系列: Web Servers

发布时间: 2019/4/26

最近更新时间: 2022/8/15

配置: 启用彻底检查

风险信息

VPR

风险因素: Critical

分数: 9.8

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:H/RL:OF/RC:C

CVSS 分数来源: CVE-2019-2725

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 9.4

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:H/RL:O/RC:C

漏洞信息

CPE: cpe:/a:oracle:weblogic_server

必需的 KB 项: www/weblogic

可利用: true

易利用性: Exploits are available

被 Nessus 利用: true

补丁发布日期: 2019/4/26

漏洞发布日期: 2019/4/24

CISA 已知利用日期: 2022/7/10

可利用的方式

Core Impact

Metasploit (Oracle Weblogic Server Deserialization RCE - AsyncResponseService)

参考资料信息

CVE: CVE-2019-2725

BID: 108074

IAVA: 2019-A-0128

CISA-NCAS: AA22-011A