Oracle Primavera Unifier 多个漏洞(2019 年 4 月 CPU)

high Nessus 插件 ID 124170
全新!漏洞优先级评级 (VPR)

Tenable 测算每个漏洞的动态 VPR。VPR 将漏洞信息与威胁情报和机器学习算法相结合,预测哪些漏洞最有可能在攻击中被利用。了解详细信息: VPR 的定义及其与 CVSS 的区别。

VPR 得分: 6.7

简介

远程 Web 服务器上运行的应用程序受到多个漏洞影响。

描述

根据其自我报告的版本号,远程 Web 服务器上运行的 Oracle Primavera Unifier 安装版本为低于 16.2.15.7 的 16.x、低于 17.12.10 的 17.7.x 或低于 18.8.6 的 18.x。因而受到多个漏洞的影响:-在 Apache Commons FileUpload 中的反序列化漏洞允许远程代码执行。(CVE-2016-1000031) - 由于设计错误,Apache HTTP Server 2.4.17 至 2.4.34 中存在拒绝服务 (DoS) 漏洞。未经身份验证的远程攻击者可利用此问题,通过发送持续大型的 SETTINGS 框架,客户端可占用连接、服务器线程和 CPU 时间,而不会出现超时连接。此问题仅影响 HTTP/2 连接。不启用 h2 协议可能缓解此问题。(CVE-2018-11763)。jackson-databind(适用于 Java 快速而强大的 JSON 库)中有一个反序列化漏洞,允许未经验证的用户执行代码。通过扩大黑名单并封锁更多来自多型反序列化的类别,即可解决此问题。(CVE-2018-19362) 请注意,Nessus 并未针对这些问题进行测试,而仅依赖应用程序自我报告的版本号。

解决方案

升级版本到 Oracle Primavera Unifier 16.2.15.7 / 17.12.10 / 18.8.6 或更高版本。

另见

http://www.nessus.org/u?9166970d

插件详情

严重性: High

ID: 124170

文件名: oracle_primavera_unifier_cpu_apr_2019.nasl

版本: 1.4

类型: remote

系列: CGI abuses

发布时间: 2019/4/19

最近更新时间: 2021/1/29

依存关系: oracle_primavera_unifier.nbin

风险信息

风险因素: High

VPR 得分: 6.7

CVSS 得分来源: CVE-2016-1000031

CVSS v2.0

基本分数: 7.5

时间分数: 5.9

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:POC/RL:OF/RC:C

CVSS v3.0

基本分数: 9.8

时间分数: 8.8

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:P/RL:O/RC:C

漏洞信息

CPE: cpe:/a:oracle:primavera_unifier

必需的 KB 项: installed_sw/Oracle Primavera Unifier, www/weblogic

可利用: true

易利用性: Exploits are available

补丁发布日期: 2019/4/16

漏洞发布日期: 2019/4/16

参考资料信息

CVE: CVE-2016-1000031, CVE-2017-9798, CVE-2018-8034, CVE-2018-11763, CVE-2018-11784, CVE-2018-19360, CVE-2018-19361, CVE-2018-19362

BID: 93604, 100872, 104895, 105414, 105524