Drupal 7.x < 7.65 / 8.5.x < 8.5.14 / 8.6.x < 8.6.13 XSS (SA-CORE-2019-004)

medium Nessus 插件 ID 123006
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器上运行的 PHP 应用程序受到跨站脚本漏洞的影响。

描述

根据其自我报告的版本,远程 Web 服务器上运行的 Drupal 实例为低于 7.65 的 7.x,低于 8.5.14 的 8.5.x 或低于 8.6.13 的 8.6.x。因此,受到文件/模块/子系统中一个跨站脚本 (XSS) 漏洞的影响,产生该漏洞的原因是未对上传文件中的数据进行正确清理。

解决方案

升级到 Drupal 7.65 / 8.5.14 / 8.6.13 或更高版本。

另见

https://www.drupal.org/sa-core-2019-004

https://www.drupal.org/project/drupal/releases/7.65

https://www.drupal.org/project/drupal/releases/8.5.14

https://www.drupal.org/project/drupal/releases/8.6.13

插件详情

严重性: Medium

ID: 123006

文件名: drupal_8_6_13.nasl

版本: 1.5

类型: remote

发布时间: 2019/3/22

最近更新时间: 2021/7/30

依存关系: drupal_detect.nasl

配置: 启用偏执模式

风险信息

CVSS 分数来源: CVE-2019-6341

VPR

风险因素: Low

分数: 3

CVSS v2

风险因素: Low

基本分数: 3.5

时间分数: 2.6

矢量: AV:N/AC:M/Au:S/C:N/I:P/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Medium

基本分数: 5.4

时间分数: 4.7

矢量: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:drupal:drupal

必需的 KB 项: installed_sw/Drupal, Settings/ParanoidReport

易利用性: No known exploits are available

补丁发布日期: 2019/3/20

漏洞发布日期: 2019/3/20

参考资料信息

CVE: CVE-2019-6341

IAVA: 2019-A-0092-S