PHP 7.0.x < 7.0.33 多个漏洞

high Nessus 插件 ID 122821
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器上运行的 PHP 版本受到多个漏洞的影响。

描述

根据其标题,远程 Web 服务器上运行的 PHP 版本为低于 7.0.33 的 7.0.x。因而受到多个漏洞的影响:- imap_open 函数中有一个任意命令注入漏洞,产生该漏洞的原因是在将邮箱名称发送至 rsh 或 ssh 命令之前,对邮箱名称的筛选不当。经身份验证的远程攻击者可利用此漏洞,通过发送特制的 IMAP 服务器名称,在目标系统上执行任意命令。(CVE-2018-19518) - phar_parse_pharfile 函数中存在堆过度读取。未经身份验证的远程攻击者可利用此情况,在尝试解析 .phar 文件时,读取通过实际数据的已分配或未分配内存。(CVE-2018-20783)

解决方案

升级至 PHP 版本 7.0.33 或更新版。

另见

http://php.net/ChangeLog-7.php#7.0.33

插件详情

严重性: High

ID: 122821

文件名: php_7_0_33.nasl

版本: 1.5

类型: remote

系列: CGI abuses

发布时间: 2019/3/13

最近更新时间: 2019/10/30

依存关系: php_version.nasl

风险信息

CVSS 分数来源: CVE-2018-19518

VPR

风险因素: High

分数: 7.4

CVSS v2

风险因素: High

基本分数: 8.5

时间分数: 7

矢量: AV:N/AC:M/Au:S/C:C/I:C/A:C

时间矢量: E:F/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 7

矢量: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:F/RL:O/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

可利用: true

易利用性: Exploits are available

补丁发布日期: 2018/12/6

漏洞发布日期: 2018/11/14

可利用的方式

Metasploit (php imap_open Remote Code Execution)

参考资料信息

CVE: CVE-2018-19518, CVE-2018-20783

BID: 106018, 107121