PHP 7.3.x < 7.3.1 多个漏洞。

critical Nessus 插件 ID 121475
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程主机上安装的应用程序受到多个漏洞的影响。

描述

根据其标题,远程 Web 服务器上运行的 PHP 版本为低于 7.3.1 的 7.3.x。因而受到多个漏洞的影响:- 在 gd_interpolation.c 的 _gdContributionsAlloc 函数中存在一个整数下溢情形。未经验证的远程攻击者可通过与递减 u 变量相关的向量,造成不明影响。(CVE-2016-10166) - gdImageColorMatch 中存在一个基于堆的缓冲区溢出情形,这是因为未正确计算配置的缓冲区大小所致。攻击者可利用此问题,通过调用 imagecolormatch 函数,并以特制影像数据作为参数。(CVE-2019-6977) - 由于未正确验证输入数据,xmlrpc_decode 函数中存在基于堆的缓冲区过度读取。未经身份验证的远程攻击者可加以恶意利用,通过特制的要求,造成堆越界读取或释放后读取情形,进而可能导致系统全面遭到入侵。(CVE-2019-9020) - PHAR 扩展的 PHAR 读取函数中存在基于堆的缓冲区过度读取情形,这是因为未正确实现内存操作所致。未经身份验证的远程攻击者可加以恶意利用,通过诱骗用户在目标系统上解析特制的文件名称,来泄露敏感信息。(CVE-2019-9021) - mbstring 正则表达式函数中存在多个基于堆的缓冲区过度读取实例,这是因为未正确实现内存操作所致。未经身份验证的远程攻击者可通过发送含有多字节序列的特制正则表达式来加以恶意利用,以造成允许攻击者全面入侵目标系统的情形。(CVE-2019-9023) - 由于未正确实现内存操作,xmlrpc_decode 函数中存在越界读取错误。未经身份验证的远程攻击者可加以恶意利用,通过恶意的 XMLRPC 服务器造成 PHP 读取分配区域之外的内存。(CVE-2019-9024) - 由于未正确实现内存操作,mb_split 函数中存在越界读取和写入错误。未经身份验证的远程攻击者可通过造成 PHP 执行具有负参数的 memcpy 函数加以恶意利用,造成缓冲区过度读取和过度写入情形,进而允许攻击者全面入侵系统。(CVE-2019-9025)

解决方案

升级到 PHP 7.3.1 或更高版本。

另见

http://php.net/ChangeLog-7.php#7.3.1

插件详情

严重性: Critical

ID: 121475

文件名: php_7_3_1.nasl

版本: 1.5

类型: remote

系列: CGI abuses

发布时间: 2019/1/30

最近更新时间: 2019/5/2

依存关系: php_version.nasl

风险信息

CVSS 分数来源: CVE-2016-10166

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.9

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:POC/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.8

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:P/RL:O/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

可利用: true

易利用性: Exploits are available

补丁发布日期: 2019/1/10

漏洞发布日期: 2019/1/10

参考资料信息

CVE: CVE-2016-10166, CVE-2019-6977, CVE-2019-9020, CVE-2019-9021, CVE-2019-9023, CVE-2019-9024, CVE-2019-9025

BID: 95869, 106731, 107156