Amazon Linux AMI : php71 (ALAS-2018-982)

critical Nessus 插件 ID 108691

简介

远程 Amazon Linux AMI 主机缺少安全更新。

描述

解析 HTTP 回应时,ext/standard/http_fopen_wrapper.c:php_stream_url_wrap_http_ex 函数中基于堆栈的缓冲区读取不足可导致拒绝服务:在 PHP 5.6.33 及之前版本、7.0.28 之前的 7.0.x 版本、7.1.14 及之前的 7.1.x 版本和 7.2.2 及之前的 7.2.x 版本中,在 ext/standard/http_fopen_wrapper.c 的 php_stream_url_wrap_http_ex 函数中解析 HTTP 响应时,存在基于堆栈的缓冲区读取不足。这进而导致复制一个大型字符串。(CVE-2018-7584)

解决方案

运行 'yum update php71' 以更新系统。

另见

https://alas.aws.amazon.com/ALAS-2018-982.html

插件详情

严重性: Critical

ID: 108691

文件名: ala_ALAS-2018-982.nasl

版本: 1.6

类型: local

代理: unix

发布时间: 2018/3/29

最近更新时间: 2019/4/5

支持的传感器: Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent

风险信息

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.9

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:POC/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.8

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:P/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:amazon:linux:php71, p-cpe:/a:amazon:linux:php71-bcmath, p-cpe:/a:amazon:linux:php71-cli, p-cpe:/a:amazon:linux:php71-common, p-cpe:/a:amazon:linux:php71-dba, p-cpe:/a:amazon:linux:php71-dbg, p-cpe:/a:amazon:linux:php71-debuginfo, p-cpe:/a:amazon:linux:php71-devel, p-cpe:/a:amazon:linux:php71-embedded, p-cpe:/a:amazon:linux:php71-enchant, p-cpe:/a:amazon:linux:php71-fpm, p-cpe:/a:amazon:linux:php71-gd, p-cpe:/a:amazon:linux:php71-gmp, p-cpe:/a:amazon:linux:php71-imap, p-cpe:/a:amazon:linux:php71-intl, p-cpe:/a:amazon:linux:php71-json, p-cpe:/a:amazon:linux:php71-ldap, p-cpe:/a:amazon:linux:php71-mbstring, p-cpe:/a:amazon:linux:php71-mcrypt, p-cpe:/a:amazon:linux:php71-mysqlnd, p-cpe:/a:amazon:linux:php71-odbc, p-cpe:/a:amazon:linux:php71-opcache, p-cpe:/a:amazon:linux:php71-pdo, p-cpe:/a:amazon:linux:php71-pdo-dblib, p-cpe:/a:amazon:linux:php71-pgsql, p-cpe:/a:amazon:linux:php71-process, p-cpe:/a:amazon:linux:php71-pspell, p-cpe:/a:amazon:linux:php71-recode, p-cpe:/a:amazon:linux:php71-snmp, p-cpe:/a:amazon:linux:php71-soap, p-cpe:/a:amazon:linux:php71-tidy, p-cpe:/a:amazon:linux:php71-xml, p-cpe:/a:amazon:linux:php71-xmlrpc, cpe:/o:amazon:linux

必需的 KB 项: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

可利用: true

易利用性: Exploits are available

补丁发布日期: 2018/3/27

参考资料信息

CVE: CVE-2018-7584

ALAS: 2018-982