Apache Tomcat 9.0.0.M1 < 9.0.5 不安全 CGI Servlet 搜索算法描述弱点

medium Nessus 插件 ID 106978

简介

远程 Apache Tomcat 服务器受到多个漏洞的影响。

描述

远程主机上安装的 Apache Tomcat 版本为低于 9.0.5 的 9.0.x。因此,其会受到安全限制缺陷的影响,导致资源暴露给未经授权的用户。
# http://tomcat.apache.org/security-9.html#Fixed_in_Apache_Tomcat_9.0.5script_set_attribute(attribute:see_also, 值:http://www.nessus.org/u?909ff130

解决方案

升级到 Apache Tomcat 9.0.5 版本或更高版本。

另见

https://tomcat.apache.org/security-9.html#Fixed_in_Apache_Tomcat_9.0.5

https://svn.apache.org/viewvc?view=rev&rev=1823310

https://svn.apache.org/viewvc?view=rev&rev=1824323

https://svn.apache.org/viewvc?view=rev&rev=1823306

https://bz.apache.org/bugzilla/show_bug.cgi?id=62067

插件详情

严重性: Medium

ID: 106978

文件名: tomcat_9_0_5.nasl

版本: 1.11

类型: combined

代理: windows, macosx, unix

系列: Web Servers

发布时间: 2018/2/23

最近更新时间: 2023/1/4

配置: 启用彻底检查

支持的传感器: Nessus Agent

风险信息

VPR

风险因素: Medium

分数: 5.1

CVSS v2

风险因素: Medium

基本分数: 4.3

时间分数: 3.2

矢量: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

时间矢量: CVSS2#E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2018-1304

CVSS v3

风险因素: Medium

基本分数: 6.5

时间分数: 5.7

矢量: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

CVSS 分数来源: CVE-2018-1305

漏洞信息

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

必需的 KB 项: installed_sw/Apache Tomcat

易利用性: No known exploits are available

补丁发布日期: 2018/2/11

漏洞发布日期: 2018/2/23

参考资料信息

CVE: CVE-2018-1304, CVE-2018-1305