JQuery 1.6.x < 1.6.3 XSS

medium Nessus 插件 ID 106656
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器受到跨站脚本漏洞的影响。

描述

根据脚本中自我报告的版本,远程 web 服务器上托管的 JQuery 版本为低于 1.6.3 的 1.6.x。因此,当使用 location.hash 选择元素时,受到跨站脚本漏洞的影响。

解决方案

请升级到 JQuery 版本 1.6.3 或更高版本。

另见

https://blog.jquery.com/2011/09/01/jquery-1-6-3-released/

插件详情

严重性: Medium

ID: 106656

文件名: jquery_1_6_3.nasl

版本: 1.4

类型: remote

发布时间: 2018/2/7

最近更新时间: 2019/5/3

依存关系: jquery_detect.nasl

配置: 启用偏执模式

风险信息

CVSS 分数来源: CVE-2011-4969

VPR

风险因素: Low

分数: 1.6

CVSS v2

风险因素: Medium

基本分数: 4.3

时间分数: 3.2

矢量: AV:N/AC:M/Au:N/C:N/I:P/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Medium

基本分数: 4.7

时间分数: 4.1

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

时间矢量: E:U/RL:O/RC:C

漏洞信息

必需的 KB 项: Settings/ParanoidReport, installed_sw/jquery

易利用性: No known exploits are available

补丁发布日期: 2011/9/1

漏洞发布日期: 2011/9/1

参考资料信息

CVE: CVE-2011-4969

BID: 58458