PHP 7.0.x < 7.0.21 多个漏洞

critical Nessus 插件 ID 101526
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器上运行的 PHP 版本受到多个漏洞的影响。

描述

根据其标题,远程 web 服务器上运行的 PHP 7.0.x 版本低于 7.0.21。因而会受到以下漏洞的影响:- PCRE 库的文件 pcre_jit_compile.c 内的 compile_bracket_matchingpath() 函数中存在越界读取错误。未经身份验证的远程攻击者可利用此问题,通过特制的正则表达,造成链接至库的进程崩溃,导致拒绝服务情况。(CVE-2017-6004) - 在处理特制 GIF 文件时,GD Graphics Library (LibGD) 的文件 gd_gif_in.c 内的 gdImageCreateFromGifCtx() 函数中存在越界读取错误。未经身份验证的远程攻击者可利用此问题,泄露敏感内存内容或造成链接至库的进程崩溃。(CVE-2017-7890) - Oniguruma 的文件 regexec.c 内的 match_at() 函数中存在越界读取错误。未经身份验证的远程攻击者可利用此问题,泄露敏感内存内容或造成链接至库的进程崩溃。(CVE-2017-9224) - 在正则表达编译过程中,Oniguruma 的 next_state_val() 函数中存在越界写入错误。未经身份验证的远程攻击者可利用此问题执行任意代码。(CVE-2017-9226) - Oniguruma 中的文件 utf8.c 内的 mbc_enc_len() 函数中存在越界读取错误。未经身份验证的远程攻击者可利用此问题,泄露内存信息或造成链接至库的进程崩溃。(CVE-2017-9227) - 在正则表达编译过程中,Oniguruma 的 bitset_set_range() 函数中存在越界写入错误。未经身份验证的远程攻击者可利用此问题执行任意代码。(CVE-2017-9228) - 在正则表达编译过程中,Oniguruma 中的文件 regexec.c 内的 left_adjust_char_head() 函数中存在无效指针引用缺陷。未经身份验证的远程攻击者可利用此问题,造成链接至库的进程崩溃,导致拒绝服务情况。(CVE-2017-9229) - 由于返回无记录值 '-1’,OpenSSL 中的文件 crypto/evp/p_seal.c 的 EVP_SealInit() 函数中存在缺陷。未经身份验证的远程攻击者可利用此问题造成不明影响。(CVE-2017-11144) - PHP 中的文件 ext/date/lib/parse_date.c 的 php_parse_date() 函数中存在越界读取错误。未经身份验证的远程攻击者可利用此问题造成拒绝服务情况或泄露内存内容。(CVE-2017-11145) - 由于在解析区域设置时未正确验证用户提供的输入,PHP 的 msgfmt_parse_message() 函数中存在基于堆栈的缓冲区溢出情况。未经身份验证的远程攻击者可利用此问题造成拒绝服务情况或执行任意代码。(CVE-2017-11362) - 由于未正确验证用户提供的输入,PHP 中的 INI 解析 API 内存在单字节溢出情况,尤其是在文件 Zend/zend_ini_parser.c 的 zend_ini_do_op() 函数中。未经身份验证的远程攻击者可利用此问题造成拒绝服务情况或执行任意代码。(CVE-2017-11628) - PHP 中的文件 ext/standard/var_unserializer.re 的 finish_nested_data() 函数中存在越界读取错误。未经身份验证的远程攻击者可利用此问题造成拒绝服务情况或泄露内存内容。(CVE-2017-12933) - PHP 中的文件 ext/standard/var_unserializer.c 的 zval_get_type() 函数中存在释放后使用错误。未经身份验证的远程攻击者可利用此问题执行任意代码。(CVE-2017-12934) 请注意,Nessus 并未针对这些问题进行测试,而仅依赖应用程序自我报告的版本号。

解决方案

升级至 PHP 版本 7.0.21 或更新版。

另见

http://php.net/ChangeLog-7.php#7.0.21

插件详情

严重性: Critical

ID: 101526

文件名: php_7_0_21.nasl

版本: 1.10

类型: remote

系列: CGI abuses

发布时间: 2017/7/13

最近更新时间: 2020/4/27

依存关系: php_version.nasl

风险信息

CVSS 分数来源: CVE-2017-12933

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No exploit is required

补丁发布日期: 2017/7/6

漏洞发布日期: 2017/5/17

参考资料信息

CVE: CVE-2017-6004, CVE-2017-7890, CVE-2017-9224, CVE-2017-9226, CVE-2017-9227, CVE-2017-9228, CVE-2017-9229, CVE-2017-11144, CVE-2017-11145, CVE-2017-11362, CVE-2017-11628, CVE-2017-12933, CVE-2017-12934

BID: 96295, 99489, 99490, 99492, 99501, 100428