VMware Workstation 12.x < 12.5.5 Multiple Vulnerabilities (VMSA-2017-0006) (Linux)

high Nessus 插件 ID 99104
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Linux 主机上安装的虚拟化应用程序受到多个漏洞的影响。

描述

远程 Linux 主机上安装的 VMware Workstation 版本为低于 12.5.5 的 12.x。因而会受到多个漏洞的影响:- 存在堆缓冲区溢出情况,造成此问题的原因是未正确验证特定输入。客户机上的攻击者可利用此问题造成拒绝服务情况或在主机上执行任意代码。(CVE-2017-4902) - 存在堆栈内存初始化缺陷,允许客户机上的攻击者在主机上执行任意代码。(CVE-2017-4903) - 内存初始化中存在不明缺陷,允许客户机上的攻击者在主机上执行任意代码。(CVE-2017-4904) - 内存初始化中存在不明缺陷,允许泄露敏感信息。(CVE-2017-4905)

解决方案

升级版本到 VMware Workstation 12.5.5 或更高版本。

另见

https://www.vmware.com/security/advisories/VMSA-2017-0006.html

插件详情

严重性: High

ID: 99104

文件名: vmware_workstation_linux_vmsa_2017_0006.nasl

版本: 1.7

类型: local

代理: unix

系列: General

发布时间: 2017/3/30

最近更新时间: 2020/9/21

依存关系: vmware_workstation_linux_installed.nbin

配置: 启用偏执模式

风险信息

CVSS 分数来源: CVE-2017-4904

VPR

风险因素: Medium

分数: 6.5

CVSS v2

风险因素: High

基本分数: 7.2

时间分数: 5.3

矢量: AV:L/AC:L/Au:N/C:C/I:C/A:C

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 8.8

时间分数: 7.7

矢量: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:vmware:workstation

必需的 KB 项: Host/VMware Workstation/Version, Settings/ParanoidReport

排除的 KB 项: SMB/Registry/Enumerated

易利用性: No known exploits are available

补丁发布日期: 2017/3/28

漏洞发布日期: 2017/3/17

参考资料信息

CVE: CVE-2017-4902, CVE-2017-4903, CVE-2017-4904, CVE-2017-4905

BID: 97160, 97163, 97164, 97165

VMSA: 2017-0006