Cisco IOS XE 集群管理协议 Telnet 选项处理 RCE (cisco-sa-20170317-cmp)

critical Nessus 插件 ID 97992
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程设备缺少供应商提供的安全修补程序。

描述

根据其自我报告的版本和配置,由于未正确处理特定 CMP 的 Telnet 选项,远程设备上运行的 Cisco IOS XE 软件受到集群管理协议 (CMP) 子系统中远程代码执行漏洞影响。未经身份验证的远程攻击者可利用此问题,通过利用畸形的特定 CMP Telnet 选项建立 Telnet 会话,以执行任意代码。

解决方案

升级到 Cisco 缺陷 ID CSCvd48893 中提及的相关修正版本。或者,作为变通方案,禁用传入连接的 Telnet 协议。

另见

http://www.nessus.org/u?7cb68237

插件详情

严重性: Critical

ID: 97992

文件名: cisco-sa-20170317-cmp-iosxe.nasl

版本: 1.9

类型: combined

系列: CISCO

发布时间: 2017/3/27

最近更新时间: 2019/4/10

依存关系: cisco_ios_xe_version.nasl

风险信息

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: Critical

基本分数: 10

时间分数: 7.8

矢量: AV:N/AC:L/Au:N/C:C/I:C/A:C

时间矢量: E:POC/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.8

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:P/RL:O/RC:C

漏洞信息

CPE: cpe:/o:cisco:ios_xe

必需的 KB 项: Host/Cisco/IOS-XE/Version

可利用: true

易利用性: Exploits are available

补丁发布日期: 2017/3/17

漏洞发布日期: 2017/3/17

参考资料信息

CVE: CVE-2017-3881

BID: 96960

CISCO-BUG-ID: CSCvd48893

IAVA: 2017-A-0073

CISCO-SA: cisco-sa-20170317-cmp