Mozilla Thunderbird < 45.7 Multiple Vulnerabilities (macOS)

critical Nessus 插件 ID 96904

简介

远程 macOS 或 Mac OS X 主机包含受多个漏洞影响的邮件客户端。

描述

远程 macOS 或 Mac OS X 主机上安装的 Mozilla Thunderbird 版本低于 45.7。因而会受到多个漏洞的影响:- Mozilla 开发人员和社区成员 Christian Holler、Gary Kwong、Andre Bargull、Jan de Mooij、Tom Schuster 和 Oriol 报告 Thunderbird 45.6 中存在内存安全错误。有迹象表明其中某些错误可导致内存损坏,我们推测若攻击者有意操控,就能利用其中部分错误来运行任意代码。(CVE-2017-5373) - JIT 代码分配可允许绕过 ASLR 和 DEP 保护,造成潜在的内存损坏攻击。(CVE-2017-5375) - 操控 XSLT 文档中的 XSL 时,存在释放后使用错误。(CVE-2017-5376) - 页面之间共享 JavaScript 对象的哈希代码。这会造成指针泄露,因为可以通过这些哈希代码发现对象的地址,还会造成使用这些哈希代码的对象内容数据泄露。(CVE-2017-5378) - 在 DOM 操控 SVG 内容期间,通过模糊测试发现潜在的释放后使用错误。(CVE-2017-5380) - 包含某些 Unicode 字符以替代连字符和引号的 URL 未正确触发 punycode 显示,允许在位置栏中发起域名欺骗攻击。(CVE-2017-5383) - 开发人员工具中的 JSON 查看器使用不安全的方法创建信道,以复制和查看 JSON 或 HTTP 标头数据,从而允许潜在的权限提升。(CVE-2017-5390) - 如果在媒体元素从内存中释放后触发某些事件,在使用媒体文件时,媒体解码器中存在释放后使用漏洞。(CVE-2017-5396) 请注意,Tenable Network Security 已直接从 Mozilla 安全公告中提取上述描述块。Tenable 已尝试在不引入其他问题的情况下尽可能进行了自动整理和排版。

解决方案

升级版本到 Mozilla Thunderbird 45.7 或更高版本。

另见

https://www.mozilla.org/en-US/security/advisories/mfsa2017-03/

https://bugzilla.mozilla.org/show_bug.cgi?id=1285833

https://bugzilla.mozilla.org/show_bug.cgi?id=1285960

https://bugzilla.mozilla.org/show_bug.cgi?id=1297361

https://bugzilla.mozilla.org/show_bug.cgi?id=1311687

https://bugzilla.mozilla.org/show_bug.cgi?id=1312001

https://bugzilla.mozilla.org/show_bug.cgi?id=1322107

https://bugzilla.mozilla.org/show_bug.cgi?id=1322315

https://bugzilla.mozilla.org/show_bug.cgi?id=1322420

https://bugzilla.mozilla.org/show_bug.cgi?id=1323338

https://bugzilla.mozilla.org/show_bug.cgi?id=1324716

https://bugzilla.mozilla.org/show_bug.cgi?id=1325200

https://bugzilla.mozilla.org/show_bug.cgi?id=1325877

https://bugzilla.mozilla.org/show_bug.cgi?id=1325938

https://bugzilla.mozilla.org/show_bug.cgi?id=1328251

https://bugzilla.mozilla.org/show_bug.cgi?id=1328834

https://bugzilla.mozilla.org/show_bug.cgi?id=1329403

https://bugzilla.mozilla.org/show_bug.cgi?id=1330769

https://bugzilla.mozilla.org/show_bug.cgi?id=1331058

插件详情

严重性: Critical

ID: 96904

文件名: macosx_thunderbird_45_7.nasl

版本: 1.8

类型: local

代理: macosx

发布时间: 2017/1/31

最近更新时间: 2019/11/13

支持的传感器: Nessus Agent

风险信息

CVSS 分数来源: CVE-2017-5396

VPR

风险因素: Critical

分数: 9.6

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:H/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 9.4

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:H/RL:O/RC:C

漏洞信息

CPE: cpe:/a:mozilla:thunderbird

必需的 KB 项: MacOSX/Thunderbird/Version

可利用: true

易利用性: Exploits are available

补丁发布日期: 2017/1/26

漏洞发布日期: 2017/1/26

参考资料信息

CVE: CVE-2017-5373, CVE-2017-5375, CVE-2017-5376, CVE-2017-5378, CVE-2017-5380, CVE-2017-5383, CVE-2017-5390, CVE-2017-5396

BID: 95757, 95758, 95762, 95769

MFSA: 2017-03