Apache Tomcat 6.0.x < 6.0.48 / 7.0.x < 7.0.73 / 8.0.x < 8.0.39 / 8.5.x < 8.5.8 多个漏洞

critical Nessus 插件 ID 95438
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Apache Tomcat 服务器受到多个漏洞的影响。

描述

根据其自我报告的版本号,远程主机上运行的 Apache Tomcat 服务版本为低于 6.0.48 的 6.0.x、低于 7.0.73 的 7.0.x、低于 8.0.39 的 8.0.x,或低于 8.5.8 的 8.5.x。因而会受到多个漏洞的影响:- 存在一个缺陷,在处理包含某个无效字符的请求行时会遭到触发。未经身份验证的远程攻击者可利用此问题,通过将额外的标头注入响应,以发动 HTTP 响应拆分攻击。(CVE-2016-6816) - 由于未正确分析过大标头导致的无限循环,HTTP/2 解析器中存在拒绝服务漏洞。经身份验证的远程攻击者可利用此问题,通过特制的请求造成拒绝服务情况。请注意,此漏洞仅影响 8.5.x 版本。(CVE-2016-6817) - 由于未正确反序列化 Java 对象,JMX 侦听器的 JmxRemoteLifecycleListener.java 中存在远程代码执行漏洞。未经身份验证的远程攻击者可利用此问题执行任意代码。(CVE-2016-8735) 请注意,Nessus 并不试图利用这些问题,而只依赖于应用程序自我报告的版本号。

解决方案

升级版本到 Apache Tomcat 6.0.48 / 7.0.73 / 8.0.39 / 8.5.8 或更高版本。

另见

http://www.nessus.org/u?1e8a81e1

http://www.nessus.org/u?1c7e7b23

http://www.nessus.org/u?833cb56a

http://www.nessus.org/u?87d6ed56

http://www.nessus.org/u?5f7bb039

插件详情

严重性: Critical

ID: 95438

文件名: tomcat_8_5_8.nasl

版本: 1.15

类型: combined

代理: windows, macosx, unix

系列: Web Servers

发布时间: 2016/12/1

最近更新时间: 2020/3/11

依存关系: tomcat_error_version.nasl, tomcat_win_installed.nbin, apache_tomcat_nix_installed.nbin

风险信息

CVSS 分数来源: CVE-2016-8735

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.9

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:POC/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.8

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:P/RL:O/RC:C

漏洞信息

CPE: cpe:/a:apache:tomcat

必需的 KB 项: installed_sw/Apache Tomcat

可利用: true

易利用性: Exploits are available

补丁发布日期: 2016/11/22

漏洞发布日期: 2016/10/10

参考资料信息

CVE: CVE-2016-6816, CVE-2016-6817, CVE-2016-8735

BID: 94097, 94461, 94463