Tenable SecurityCenter < 5.3.0 多种漏洞 (TNS-2016-04)

medium Nessus 插件 ID 93343
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程主机上安装的 Tenable SecurityCenter 应用程序受到多种漏洞影响。

描述

远程主机上安装的 Tenable SecurityCenter 应用程序为 5.3.0 之前的版本,或缺少安全修补程序。因此,它受到 PHP 随附的 Perl-Compatible Regular Expressions (PCRE) 库中的多种漏洞影响:

- PCRE 库中存在溢出,造成此漏洞的原因是处理重复的有条件群组时,未正确验证用户提供的输入。攻击者可利用此漏洞,通过特别构建的正则表达式造成缓冲区溢出,进而导致拒绝服务。(CVE-2015-8383)

- PCRE 库中存在溢出,造成此漏洞的原因是处理“lookbehind”断言中的相互递归时,未正确验证用户提供的输入。攻击者可借此造成基于堆栈的缓冲区溢出,进而导致拒绝服务。
(CVE-2015-8386)

- PCRE 库中存在整数溢出,造成此漏洞的原因是处理子例程调用时,未正确验证用户提供的输入。攻击者可利用此缺陷,通过特别构建的正则表达式造成拒绝服务情况。(CVE-2015-8387)

- PCRE 库中存在一个缺陷,造成此缺陷的原因是未正确处理 /(?:|a|){100}x/ 模式或其他相关模式。攻击者可利用此缺陷,通过特别构建的正则表达式造成无限递归,进而导致拒绝服务。
(CVE-2015-8389)

- PCRE 库中存在一个缺陷,造成此缺陷的原因是未正确处理字符类中的 [: 和 \\ 子字符串。攻击者可利用此缺陷,通过特别构建的正则表达式造成未初始化的内存读取,进而导致拒绝服务。
(CVE-2015-8390)

- PCRE 库 pcre_compile.c 的 pcre_compile() 函数中存在一个缺陷,造成此缺陷的原因是未正确处理 [: 嵌套。攻击者可利用此缺陷,通过特别构建的正则表达式造成过度消耗 CPU 资源,进而导致拒绝服务。(CVE-2015-8391)

- PCRE 库中存在一个缺陷,造成此缺陷的原因是未正确处理二进制文件的“-q”选项。攻击者可利用此缺陷,通过特别构建的文件泄露敏感信息。(CVE-2015-8393)

- PCRE 库中存在整数溢出,造成此漏洞的原因是处理 (?(<digits>) 和 (?(R<digits>) 条件时,未正确验证用户提供的输入。
攻击者可利用此缺陷,通过特别构建的正则表达式造成拒绝服务情况。(CVE-2015-8394)

请注意,Nessus 并未测试这些问题,而是只依赖于应用程序自我报告的版本号。

解决方案

升级到 SecurityCenter 5.3.0 或更高版本。或者,应用修补程序 SC-201603.1-5.x-rh5-64.tgz / SC-201603.1-5.x-rh6-64.tgz。

另见

https://www.tenable.com/security/tns-2016-04

https://secure.php.net/ChangeLog-5.php#5.6.18

插件详情

严重性: Medium

ID: 93343

文件名: securitycenter_php_5_6_18.nasl

版本: 1.12

类型: combined

代理: unix

系列: Misc.

发布时间: 2016/9/6

最近更新时间: 2020/10/9

依存关系: securitycenter_installed.nbin, securitycenter_detect.nbin

风险信息

CVSS 分数来源: manual

CVSS 分数理由: Score based on analysis of the vendor advisory.

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: Medium

基本分数: 4

时间分数: 3

矢量: AV:N/AC:L/Au:S/C:N/I:N/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Medium

基本分数: 4.3

时间分数: 3.8

矢量: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:tenable:securitycenter

必需的 KB 项: Host/SecurityCenter/Version, installed_sw/SecurityCenter, Host/SecurityCenter/support/php/version

易利用性: No known exploits are available

补丁发布日期: 2016/3/8

漏洞发布日期: 2015/11/23

参考资料信息

CVE: CVE-2015-8383, CVE-2015-8386, CVE-2015-8387, CVE-2015-8389, CVE-2015-8390, CVE-2015-8391, CVE-2015-8393, CVE-2015-8394

BID: 79810, 82990