Ubuntu 16.04 LTS:Linux 内核 (Qualcomm Snapdragon) 漏洞 (USN-3070-3)

high Nessus 插件 ID 93242

简介

远程 Ubuntu 主机缺少一个或多个安全更新。

描述

远程 Ubuntu 16.04 LTS 主机上安装的一个程序包受到 USN-3070-3 公告中提及的多个漏洞影响。

- 在 4.6.3 及之前的 Linux 内核中,nfsd 允许本地用户设置 POSIX ACL,进而绕过预期文件权限限制;此问题与 nfs2acl.c、nfs3acl.c 和 nfs4acl.c 相关。(CVE-2016-1237)

- 在 Linux 内核 4.6.3 及之前版本中,net/rds/recv.c 中的 rds_inc_info_copy 函数未初始化特定结构成员,远程攻击者可利用此漏洞,通过读取 RDS 消息,从内核堆栈内存获取敏感信息。(CVE-2016-5244)

- 在 4.7 之前的 Linux 内核中,airspy USB 驱动程序中的 drivers/media/usb/airspy/airspy.c 的 airspy_probe 函数存在内存泄露漏洞,导致本地用户可以通过构建模拟许多 VFL_TYPE_SDR or VFL_TYPE_SUBDEV 设备并执行许多连接和断开连接操作的 USB 设备,造成拒绝服务(内存消耗)。(CVE-2016-5400)

- 在 4.7 之前的 Linux 内核中,net/ipv4/tcp_input.c 未正确判断质询 ACK 区段率,进而使远程攻击者更容易通过盲目式窗口内攻击,劫持 TCP 会话。
(CVE-2016-5696)

- 在 4.6.1 之前的 Linux 内核中,MIC VOP 驱动程序的 drivers/misc/mic/vop/vop_vringh.c 中的 vop_ioctl 函数存在争用条件漏洞,导致可以通过更改特定标头,从内核内存获取敏感信息或造成拒绝服务(内存损坏和系统崩溃),也称为双重提取漏洞。(CVE-2016-5728)

- 在 powerpc 平台 4.6.3 及之前的 Linux 内核中,arch/powerpc/kernel/process.c 的 start_thread 函数不当处理交易状态,其允许本地用户在执行 exec 系统调用之前,启动和暂停交易,进而造成拒绝服务(无效进程状态或 TM Bad Thing 异常,以及系统崩溃),或可能造成其他不明影响。(CVE-2016-5828)

- 在 4.6.3 及之前的 Linux 内核中,drivers/hid/usbhid/hiddev.c 的 hiddev_ioctl_usage 函数中多个基于堆的缓冲区溢出问题允许本地用户造成拒绝服务,或可能会通过特制的 (1) HIDIOCGUSAGES 或 (2) HIDIOCSUSAGES ioctl 调用造成其他不明影响。(CVE-2016-5829)

- 在 4.6 之前的 Linux 内核中,OverlayFS 文件系统的实现中的 fs/overlayfs/dir.c 在进行取消链接和重命名系统调用处理前未正确验证上 dentry,这允许本地用户通过指定自硬链接的重命名系统调用造成拒绝服务(系统崩溃)。(CVE-2016-6197)

请注意,Nessus 尚未测试这些问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

更新受影响的 kernel 程序包。

另见

https://ubuntu.com/security/notices/USN-3070-3

插件详情

严重性: High

ID: 93242

文件名: ubuntu_USN-3070-3.nasl

版本: 2.12

类型: local

代理: unix

发布时间: 2016/8/31

最近更新时间: 2024/1/9

支持的传感器: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent, Nessus

风险信息

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: High

基本分数: 7.2

时间分数: 5.6

矢量: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS 分数来源: CVE-2016-5829

CVSS v3

风险因素: High

基本分数: 7.8

时间分数: 7

矢量: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

时间矢量: CVSS:3.0/E:P/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:canonical:ubuntu_linux:linux-image-4.4.0-1024-snapdragon, cpe:/o:canonical:ubuntu_linux:16.04:-:lts

必需的 KB 项: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

可利用: true

易利用性: Exploits are available

补丁发布日期: 2016/8/30

漏洞发布日期: 2016/6/27

参考资料信息

CVE: CVE-2016-1237, CVE-2016-5244, CVE-2016-5400, CVE-2016-5696, CVE-2016-5728, CVE-2016-5828, CVE-2016-5829, CVE-2016-6197

USN: 3070-3