VMware Workstation 12.1.x < 12.1.1 共享文件夹 (HGFS) 客户机 DLL 劫持任意代码执行 (VMSA-2016-0010) (Linux)

high Nessus 插件 ID 92946

简介

远程主机上安装的虚拟化应用程序受到一个任意代码执行漏洞影响。

描述

远程主机上安装的 VMware Workstation 版本是低于 12.1.1 的 12.1.x。由于从不安全的路径不当加载动态链接库 (DLL) 文件(包括目前的工作路径),而这些文件可能不受用户控制,因而导致共享文件夹 (HGFS) 功能受到一个任意代码执行漏洞影响。远程攻击者可利用此漏洞,在路径中放置恶意 DLL 或诱骗用户打开网络共享上的文件,进而在目前用户的上下文中注入并执行任意代码。

解决方案

升级到 VMware Workstation 12.1.1 或更高版本。

请注意,也必须更新使用共享文件夹 (HGFS) 功能的基于 Windows 的客户机的 VMware Tools,才能完全减轻漏洞的影响。

另见

http://www.vmware.com/security/advisories/VMSA-2016-0010.html

插件详情

严重性: High

ID: 92946

文件名: vmware_workstation_linux_vmsa_2016_0010.nasl

版本: 1.9

类型: local

代理: unix

系列: General

发布时间: 2016/8/12

最近更新时间: 2020/9/21

支持的传感器: Nessus Agent

风险信息

VPR

风险因素: High

分数: 7.4

CVSS v2

风险因素: Medium

基本分数: 4.4

时间分数: 3.6

矢量: AV:L/AC:M/Au:N/C:P/I:P/A:P

时间矢量: E:F/RL:OF/RC:C

CVSS 分数来源: CVE-2016-5330

CVSS v3

风险因素: High

基本分数: 7.8

时间分数: 7.2

矢量: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

时间矢量: E:F/RL:O/RC:C

漏洞信息

CPE: cpe:/a:vmware:workstation

必需的 KB 项: Host/VMware Workstation/Version

排除的 KB 项: SMB/Registry/Enumerated

可利用: true

易利用性: Exploits are available

补丁发布日期: 2016/8/4

漏洞发布日期: 2016/8/4

可利用的方式

Metasploit (DLL Side Loading Vulnerability in VMware Host Guest Client Redirector)

参考资料信息

CVE: CVE-2016-5330

BID: 92323

VMSA: 2016-0010