PHP 5.5.x < 5.5.37 多种漏洞

critical Nessus 插件 ID 91897

简介

远程 Web 服务器上运行的 PHP 版本受到多种漏洞的影响。

描述

根据其标题,远程 web 服务器上运行的 PHP 5.5.x 版本低于 5.5.37。因此,它受到多种漏洞的影响:

- 处理特别构建的图像(包含超大的负坐标)时,gd.c 文件内 gdImageFillToBorder() 函数的 GD 图形库中存在一个拒绝服务漏洞。未经认证的远程攻击者可利用此问题,通过特别构建的图像造成链接到库的进程崩溃。
(CVE-2015-8874)

- 文件 ext/gd/libgd/gd_gd2.c 中的
_gd2GetHeader() 函数存在一个整数溢出情况,这是由于未正确验证用户提供的输入所致。未经认证的远程攻击者可利用此问题造成拒绝服务情况或执行任意代码。(CVE-2016-5766)

- 文件 ext/gd/libgd/gd.c 中的
gdImagePaletteToTrueColor() 函数存在一个整数溢出情况,这是由于未正确验证用户提供的输入所致。未经认证的远程攻击者可利用此问题造成拒绝服务情况或执行任意代码。(CVE-2016-5767)

- 处理失败的回调执行时,
文件 ext/mbstring/php_mbregex.c 中的 _php_mb_regex_ereg_replace_exec() 函数存在一个双重释放错误。未经认证的远程攻击者可利用此问题执行任意代码。
(CVE-2016-5768)

- 文件 ext/mcrypt/mcrypt.c 中存在一个整数溢出情况,这是因为处理数据值时未正确验证用户提供的输入所致。未经认证的远程攻击者可利用此问题造成拒绝服务情况或执行任意代码。(CVE-2016-5769)

- 文件 ext/spl/spl_directory.c 中存在一个整数溢出情况,由 int/size_t 类型混淆错误触发,允许未经认证的远程攻击者造成不明影响。
(CVE-2016-5770)

- 文件 ext/spl/spl_array.c 中的垃圾收集算法存在一个释放后使用错误。未经认证的远程攻击者可利用此问题取消引用已经释放的内存,从而导致执行任意代码。(CVE-2016-5771)

- 处理特别构建的 XML 内容时,文件 ext/wddx/wddx.c 中的 php_wddx_process_data() 函数存在一个双重释放错误。未经认证的远程攻击者可利用此问题执行任意代码。
(CVE-2016-5772)

- 文件 ext/zip/php_zip.c 中的垃圾收集算法存在一个释放后使用错误。未经认证的远程攻击者可利用此问题取消引用已经释放的内存,从而导致执行任意代码。(CVE-2016-5773)

- 文件 ext/standard/php_smart_str.h 中的 json_decode() 和 json_utf8_to_utf16() 函数存在一个整数溢出情况,这是由于未正确验证用户提供的输入所致。未经认证的远程攻击者可利用此问题造成拒绝服务情况或执行任意代码。
(VulnDB 140378)

- 文件 ext/gd/libgd/gd_topal.c 中的 pass2_no_dither() 函数存在一个越界读取错误,允许未经认证的远程攻击者造成拒绝服务或泄露内存内容。(VulnDB 140379)

- 处理字符串长度时,文件 ext/standard/string.c 中存在一个整数溢出情况,这是由于未正确验证用户提供的输入所致。未经认证的远程攻击者可利用此问题造成不明影响。(VulnDB 140380)

- 文件 ext/gd/libgd/gd_interpolation.c 中的
_gdScaleVert() 函数存在一个空指针取消引用缺陷,该缺陷在处理 _gdContributionsCalc 返回值时触发。未经认证的远程攻击者可利用此缺陷造成拒绝服务。(VulnDB 140382)

- 文件 ext/standard/string.c 中的 nl2br() 函数处理 new_length 值时存在一个整数溢出情况,这是因为不当验证用户提供的输入所导致。未经认证的远程攻击者可利用此问题造成不明影响。
(VulnDB 140385)

- 处理字符串值时,文件 ext/standard/string.c 中的多个函数存在一个整数溢出情况,这是由于未正确验证用户提供的输入所致。未经认证的远程攻击者可利用此问题造成不明影响。
(VulnDB 140386)

请注意,Nessus 并未测试这些问题,而是只依赖于应用程序自我报告的版本号。

解决方案

升级至 PHP 版本 5.5.37 或更新版。

另见

http://php.net/ChangeLog-5.php#5.5.37

插件详情

严重性: Critical

ID: 91897

文件名: php_5_5_37.nasl

版本: 1.16

类型: remote

系列: CGI abuses

发布时间: 2016/7/1

最近更新时间: 2022/4/11

风险信息

CVSS 分数来源: CVE-2016-5768

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No exploit is required

补丁发布日期: 2016/6/23

漏洞发布日期: 2014/1/2

参考资料信息

CVE: CVE-2015-8874, CVE-2016-5766, CVE-2016-5767, CVE-2016-5768, CVE-2016-5769, CVE-2016-5770, CVE-2016-5771, CVE-2016-5772, CVE-2016-5773

BID: 90714, 91393, 91395, 91396, 91397, 91398, 91399, 91401, 91403