Samba Badlock 漏洞

high Nessus 插件 ID 90509

简介

远程主机上运行的 SMB 服务器受到 Badlock 漏洞的影响。

描述

远程主机上运行的 Samba(适用于 Linux 和 Unix 的 CIFS/SMB 服务器)版本受到 Security Account Manager (SAM) 与本地安全机构(域策略)(LSAD) 协议中一个称为 Badlock 的缺陷影响,这是由于未通过远程过程调用 (RPC) 通道正确进行认证级别协商所导致。若中间人攻击者能够拦截客户端与托管 SAM 数据库的服务器之间的流量,便可利用此缺陷,强制降级认证级别,进而允许在拦截用户的上下文中执行任意 Samba 网络调用,例如查看或修改 Active Directory (AD) 数据库中的敏感安全数据,或禁用重要服务。

解决方案

升级到 Samba 版本 4.2.11 / 4.3.8 / 4.4.2 或更高版本。

另见

http://badlock.org

https://www.samba.org/samba/security/CVE-2016-2118.html

插件详情

严重性: High

ID: 90509

文件名: samba_badlock.nasl

版本: 1.8

类型: remote

系列: General

发布时间: 2016/4/13

最近更新时间: 2019/11/20

风险信息

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: Medium

基本分数: 6.8

时间分数: 5

矢量: AV:N/AC:M/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2016-2118

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:samba:samba

必需的 KB 项: SMB/samba, SMB/name, SMB/transport

易利用性: No known exploits are available

补丁发布日期: 2016/4/12

漏洞发布日期: 2016/3/23

参考资料信息

CVE: CVE-2016-2118

BID: 86002

CERT: 813296