PHP 5.5.x < 5.5.33 多种漏洞

critical Nessus 插件 ID 90007
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器使用受多种漏洞影响的 PHP 版本。

描述

根据其标题,远程 web 服务器上运行的 PHP 5.5.x 版本低于 5.5.33。因此,它受到多种漏洞的影响:

- 处理 XML 数据时,文件 ext/wddx/wddx.c 的 php_wddx_pop_element() 函数中存在一个释放后使用错误。未经认证的远程攻击者可利用此错误,通过特别构建的 XML 数据取消引用已释放的内存,进而导致任意代码执行。
(CVE-2016-3141)

- 文件 ext/phar/zip.c 的 phar_parse_zipfile() 函数中存在一个越界读取错误,其允许未经认证的远程攻击者造成拒绝服务,或取得敏感信息的访问权限。(CVE-2016-3142)

请注意,Nessus 并未测试这些问题,而是只依赖于应用程序自我报告的版本号。

解决方案

升级至 PHP 版本 5.5.33 或更新版。

另见

http://php.net/ChangeLog-5.php#5.5.33

插件详情

严重性: Critical

ID: 90007

文件名: php_5_5_33.nasl

版本: 1.14

类型: remote

系列: CGI abuses

发布时间: 2016/3/17

最近更新时间: 2019/11/20

依存关系: php_version.nasl

风险信息

CVSS 分数来源: CVE-2016-3141

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No exploit is required

补丁发布日期: 2016/3/3

漏洞发布日期: 2016/3/2

参考资料信息

CVE: CVE-2016-3141, CVE-2016-3142

BID: 84271, 84306, 84307, 84348, 84349, 84350, 84351