Squid 3.x < 3.5.15 / 4.x < 4.0.7 多种 DoS

high Nessus 插件 ID 89080
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程代理服务器可能受到多种拒绝服务漏洞的影响。

描述

根据其标题,远程主机上运行的 Squid 版本为低于 3.5.15 的 3.x 或低于 4.0.7 的 4.x。因此,可能受到多种拒绝服务漏洞的影响:

- 存在一个无法正确将数据附加至 String 对象的缺陷。远程攻击者可利用此缺陷,通过构建的 HTTP Vary 标头,造成断言失败和后台程序退出,进而导致拒绝服务。(CVE-2016-2569)

- Edge Side Includes (ESI) 解析器中存在一个缺陷,这是因为 XML 解析期间检查缓冲区限制失败所导致。
远程攻击者可利用此缺陷,通过构建的 XML 文档造成断言失败和后台程序退出,进而导致拒绝服务。(CVE-2016-2570)

- http.cc 中存在一个缺陷,允许在响应解析失败后仍储存某些数据。远程攻击者可利用此问题,通过畸形服务器响应,造成断言失败及后台程序退出,进而导致拒绝服务。
CVE-2016-2571)

- http.cc 中存在一个缺陷,这是因为在响应解析失败后仍依赖 HTTP 状态代码所导致。远程攻击者可利用此问题,通过畸形服务器响应,造成断言失败及后台程序退出,进而导致拒绝服务。
(CVE-2016-2572)

请注意,Nessus 并未测试这些问题,而是只依赖于应用程序自我报告的版本号。
此外,发布用于解决这些问题的修补程序不会更新标题中的版本。如果已正确应用修补程序并重新启动服务,请将此视为误报。

解决方案

升级到 Squid 3.5.15 / 4.0.7 或更高版本。或者,应用供应商提供的修补程序。

另见

http://www.squid-cache.org/Advisories/

http://www.squid-cache.org/Advisories/SQUID-2016_2.txt

插件详情

严重性: High

ID: 89080

文件名: squid_4_0_7.nasl

版本: 1.5

类型: remote

系列: Firewalls

发布时间: 2016/3/2

最近更新时间: 2019/11/20

依存关系: squid_version.nasl

配置: 启用偏执模式

风险信息

CVSS 分数来源: CVE-2016-2572

VPR

风险因素: Low

分数: 3.6

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: AV:N/AC:L/Au:N/C:N/I:N/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:squid-cache:squid

必需的 KB 项: www/squid, Settings/ParanoidReport

易利用性: No known exploits are available

补丁发布日期: 2016/2/23

漏洞发布日期: 2016/2/23

参考资料信息

CVE: CVE-2016-2569, CVE-2016-2570, CVE-2016-2571, CVE-2016-2572