Oracle Linux 5:openssl (ELSA-2016-0302) (DROWN)

high Nessus 插件 ID 89065

简介

远程 Oracle Linux 主机缺少一个或多个安全更新。

描述

来自 Red Hat 安全公告 2016:0302:

更新后的 openssl 程序包修复了三个安全问题,现在可用于 Red Hat Enterprise Linux 5

Red Hat 产品安全团队将此更新评级为具有重要安全影响。可从“参考”部分中的 CVE 链接获取针对每个漏洞的通用漏洞评分系统 (CVSS) 基本分数,其给出了详细的严重性等级。

OpenSSL 是用于实现安全套接字层 (SSL v2/v3) 和传输层安全 (TLS v1) 协议以及强大的通用密码库的工具包。

在安全套接字层 2.0 版 (SSLv2) 协议中发现一个 padding oracle 缺陷。攻击者可能利用此缺陷,从使用较新 SSL/TLS 协议版本的连接解密 RSA 加密的密码文本,使其能够解密此类连接。
此跨协议攻击公开称为 DROWN。
(CVE-2016-0800)

注意:此问题已通过在使用“SSLv23”连接方法时默认禁用 SSLv2 协议,并删除对于弱 SSLv2 加密套件的支持来解决。您可以在启动需要启用 SSLv2 的应用程序之前设置 OPENSSL_ENABLE_SSL2 环境变量,来在“SSLv23”连接方法中重新启用 SSLv2 协议。有关更多信息,请参阅“参考”部分中链接的知识库文章。

在恶意 SSLv2 客户端可协商已在服务器上禁用的 SSLv2 密码的方式中发现一个缺陷。这可导致弱 SSLv2 密码用于 SSLv2 连接,使其容易遭受中间人攻击。(CVE-2015-3197)

在系统实现 OpenSSL 的 BIGNUM 函数的方式中发现一个整数溢出缺陷,其导致空指针取消引用或基于堆的内存损坏。使用这些包含大型不受信任输入的函数的应用程序可能崩溃,或可能执行任意代码。(CVE-2016-0797)

Red Hat 在此感谢 OpenSSL 项目报告这些问题。上游感谢 CVE-2016-0800 和 CVE-2015-3197 的原始报告者 Nimrod Aviram 和 Sebastian Schinzel,以及 CVE-2016-0797 的原始报告者 Guido Vranken。

建议所有 openssl 用户升级这些更新后的程序包,其中包含用于修正这些问题的向后移植的修补程序。为使更新生效,必须重新启动所有链接到 OpenSSL 库的服务,或重新启动系统。

解决方案

更新受影响的 openssl 程序包。

另见

https://oss.oracle.com/pipermail/el-errata/2016-March/005833.html

插件详情

严重性: High

ID: 89065

文件名: oraclelinux_ELSA-2016-0302.nasl

版本: 2.19

类型: local

代理: unix

发布时间: 2016/3/2

最近更新时间: 2021/1/14

支持的传感器: Frictionless Assessment Agent, Nessus Agent

风险信息

VPR

风险因素: Medium

分数: 5.1

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: AV:N/AC:L/Au:N/C:N/I:N/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:oracle:linux:openssl, p-cpe:/a:oracle:linux:openssl-devel, p-cpe:/a:oracle:linux:openssl-perl, cpe:/o:oracle:linux:5

必需的 KB 项: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

易利用性: No known exploits are available

补丁发布日期: 2016/3/1

漏洞发布日期: 2016/2/15

参考资料信息

CVE: CVE-2015-3197, CVE-2016-0797, CVE-2016-0800

RHSA: 2016:0302