PHP 5.6.x < 5.6.14 多种漏洞

high Nessus 插件 ID 86301

简介

远程 Web 服务器使用受多种漏洞影响的 PHP 版本。

描述

根据其标题,远程 web 服务器上运行的 PHP 5.6.x 版本低于 5.6.14。因此,它受到多种漏洞的影响:

- ext/phar/util.c 的 phar_get_fp_offset() 函数中存在空指针取消引用缺陷,当其指向不存在的文件时就会触发此缺陷。未经认证的远程攻击者可利用此缺陷造成拒绝服务。(OSVDB 128347)

- ext/phar/dirstream.c 中的 phar_make_dirstream() 函数中存在一个未初始化指针缺陷,该缺陷在处理形式为正斜线的 zip 条目文件名时触发。未经认证的远程攻击者可利用此问题造成拒绝服务情况或泄露敏感信息。
(OSVDB 128348)

请注意,Nessus 并未测试这些问题,而是只依赖于应用程序自我报告的版本号。

解决方案

升级至 PHP 版本 5.6.14 或更新版。

另见

http://php.net/ChangeLog-5.php#5.6.14

插件详情

严重性: High

ID: 86301

文件名: php_5_6_14.nasl

版本: 1.14

类型: remote

系列: CGI abuses

发布时间: 2015/10/6

最近更新时间: 2022/4/11

配置: 启用彻底检查

风险信息

VPR

风险因素: High

分数: 7.4

CVSS v2

风险因素: Medium

基本分数: 6.8

时间分数: 5

矢量: AV:N/AC:M/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2015-7803

CVSS v3

风险因素: High

基本分数: 8.6

时间分数: 7.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No known exploits are available

补丁发布日期: 2015/10/1

漏洞发布日期: 2015/5/28

参考资料信息

CVE: CVE-2015-7803, CVE-2015-7804

BID: 76959