PHP 5.5.x < 5.5.29 多种漏洞

high Nessus 插件 ID 85886
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器使用受多种漏洞影响的 PHP 版本。

描述

根据其标题,远程 web 服务器上运行的 PHP 5.5.x 版本低于 5.5.29。因此,它受到以下漏洞的影响:

- 存在多个与 unserialize() 函数相关的释放后使用内存错误。远程攻击者可利用这些错误执行任意代码。
(CVE-2015-6834)

- 存在与 php_var_unserialize() 函数相关的一个释放后使用内存错误。远程攻击者可以使用构建的序列化字符串,利用此错误执行任意代码。(CVE-2015-6835)

- 由于未正确认证标头字段,存在与 serialize_function_call() 函数相关的类型混淆错误。远程攻击者可以利用此错误造成不明影响。(CVE-2015-6836)

- 由于未正确认证 libxslt 库的输入,XSLTProcessor 类中存在多个缺陷。远程攻击者可利用这些缺陷造成不明影响。(CVE-2015-6837、CVE-2015-6838)

- 由于未正确审查用户提供的输入,php_zip.c 文件中的 php_zip_extract_file() 函数中存在一个缺陷。未经认证的远程攻击者可利用此缺陷在限制路径之外创建任意目录。(OSVDB 127122)

请注意,Nessus 并未测试这些问题,而是只依赖于应用程序自我报告的版本号。

解决方案

升级至 PHP 版本 5.5.29 或更新版。

另见

http://php.net/ChangeLog-5.php#5.5.29

插件详情

严重性: High

ID: 85886

文件名: php_5_5_29.nasl

版本: 1.19

类型: remote

系列: CGI abuses

发布时间: 2015/9/10

最近更新时间: 2021/1/19

依存关系: php_version.nasl

风险信息

CVSS 分数来源: CVE-2015-6836

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.9

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:POC/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.3

时间分数: 6.6

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

时间矢量: E:P/RL:O/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

可利用: true

易利用性: No exploit is required

补丁发布日期: 2015/9/3

漏洞发布日期: 2014/9/10

参考资料信息

CVE: CVE-2014-9767, CVE-2015-6834, CVE-2015-6835, CVE-2015-6836, CVE-2015-6837, CVE-2015-6838

BID: 76644, 76649, 76652, 76733, 76734, 76738