CentOS 6:libxml2 (CESA-2015:1419)

medium Nessus 插件 ID 85019

简介

远程 CentOS 主机缺少一个或多个安全更新。

描述

更新后的 libxml2 程序包修复了一个安全问题和一个缺陷,现在可用于 Red Hat Enterprise Linux 6。

Red Hat 产品安全团队将此更新评级为具有低安全影响。可从“参考”部分中的 CVE 链接获取通用漏洞评分系统 (CVSS) 基本分数,其给出了详细的严重性等级。

libxml2 库是提供各种 XML 标准实现的开发工具箱。

在 libxml2 库解析特定 XML 文件的方式中发现拒绝服务缺陷。攻击者可以提供特别构建的 XML 文件,当应用程序使用 libxml2 解析该文件时,可导致该应用程序占用过多内存。
(CVE-2015-1819)

此问题由 Red Hat 产品安全的 Florian Weimer 发现。

此更新还修复以下缺陷:

此更新修复了针对 HTML 文档序列化运行测试用例时出现的错误。(BZ#1004513)

建议所有 libxml2 用户升级这些更新后的程序包,其中包含用于修正这些问题的向后移植的修补程序。必须重新启动(注销,然后再登录)桌面才能使此更新生效。

解决方案

更新受影响的 libxml2 程序包。

另见

http://www.nessus.org/u?18612b78

插件详情

严重性: Medium

ID: 85019

文件名: centos_RHSA-2015-1419.nasl

版本: 2.6

类型: local

代理: unix

发布时间: 2015/7/28

最近更新时间: 2021/1/4

支持的传感器: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure

风险信息

VPR

风险因素: Medium

分数: 5.1

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: AV:N/AC:L/Au:N/C:N/I:N/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2015-1819

漏洞信息

CPE: p-cpe:/a:centos:centos:libxml2, p-cpe:/a:centos:centos:libxml2-devel, p-cpe:/a:centos:centos:libxml2-python, p-cpe:/a:centos:centos:libxml2-static, cpe:/o:centos:centos:6

必需的 KB 项: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

易利用性: No known exploits are available

补丁发布日期: 2015/7/26

漏洞发布日期: 2015/8/14

参考资料信息

CVE: CVE-2015-1819

BID: 75570

RHSA: 2015:1419