RHEL 7:wpa_supplicant (RHSA-2015:1090)

medium Nessus 插件 ID 84142
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Red Hat 主机缺少一个或多个安全更新。

描述

更新后的 wpa_supplicant 程序包修复了两个安全问题并添加了一项增强,现在可用于 Red Hat Enterprise Linux 7。

Red Hat 产品安全团队将此更新评级为具有重要安全影响。可从“参考”部分中的 CVE 链接获取针对每个漏洞的通用漏洞评分系统 (CVSS) 基本分数,其给出了详细的严重性等级。

wpa_supplicant 程序包包含 802.1X 请求方,支持 WEP、WPA、WPA2 (IEEE 802.11i / RSN) 及各种 EAP 认证方法。它与客户端工作站的 WPA 认证程序实现密钥协商,并控制漫游和 IEEE 802.11 认证以及 WLAN 驱动程序关联。

发现 wpa_supplicant 处理 Wi-Fi Direct / P2P 管理框架中的 SSID 信息的方式中存在缓冲区溢出缺陷。如果攻击者处于 Wi-Fi 的辐射范围内,则可能利用特别构建的框架导致 wpa_supplicant 崩溃或执行任意代码。(CVE-2015-1863)

已发现在 wpa_supplicant 处理 WMM 操作框架的方式中存在导致缓冲区读取越界的整数下溢缺陷。如果攻击者处于 Wi-Fi 的辐射范围内,则可能利用特别构建的框架导致 wpa_supplicant 崩溃。(CVE-2015-4142)

Red Hat 在此感谢 wpa_supplicant 上游的 Jouni Malinen 报告 CVE-2015-1863 问题。上游感谢原始报告者 Alibaba 安全团队。

此更新还添加了以下增强:

* 在此更新之前,wpa_supplicant 不提供需要在 X.509 证书的公用名或主体别名中列出的主机名的方式,并且仅允许主机名后缀或主题子字符串检查。此更新引入一个新的配置指令“domain_match”,该指令添加了完整主机名检查。
(BZ#1178263)

建议所有 wpa_supplicant 用户升级此更新后的程序包,其中包含用于修正这些问题的向后移植的修补程序,并且添加了此增强。安装此更新后, wpa_supplicant 服务将自动重新启动。

解决方案

更新受影响的 wpa_supplicant 和/或 wpa_supplicant-debuginfo 程序包。

另见

https://access.redhat.com/errata/RHSA-2015:1090

https://access.redhat.com/security/cve/cve-2015-4142

https://access.redhat.com/security/cve/cve-2015-1863

插件详情

严重性: Medium

ID: 84142

文件名: redhat-RHSA-2015-1090.nasl

版本: 2.17

类型: local

代理: unix

发布时间: 2015/6/12

最近更新时间: 2021/2/5

依存关系: ssh_get_info.nasl

风险信息

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: Medium

基本分数: 5.8

时间分数: 5

矢量: AV:A/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:ND/RL:OF/RC:C

漏洞信息

CPE: p-cpe:/a:redhat:enterprise_linux:wpa_supplicant, p-cpe:/a:redhat:enterprise_linux:wpa_supplicant-debuginfo, cpe:/o:redhat:enterprise_linux:7, cpe:/o:redhat:enterprise_linux:7.1, cpe:/o:redhat:enterprise_linux:7.2, cpe:/o:redhat:enterprise_linux:7.3, cpe:/o:redhat:enterprise_linux:7.4, cpe:/o:redhat:enterprise_linux:7.5, cpe:/o:redhat:enterprise_linux:7.6, cpe:/o:redhat:enterprise_linux:7.7

必需的 KB 项: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

易利用性: No known exploits are available

补丁发布日期: 2015/6/11

漏洞发布日期: 2015/4/28

参考资料信息

CVE: CVE-2015-1863, CVE-2015-4142

BID: 74296, 74549

RHSA: 2015:1090