PHP 5.4.x < 5.4.41 多种漏洞

critical Nessus 插件 ID 83517
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器使用受多种漏洞影响的 PHP 版本。

描述

根据其标题,远程 Web 服务器上运行的 PHP 5.4.x 版本低于 5.4.41。因此,它受到多种漏洞的影响:

- 存在多种与使用包含空字节的路径名相关的缺陷。远程攻击者可以利用这些漏洞,通过结合“\0”字符和安全文件扩展绕过访问限制。此缺陷之前已修复,但由于版本 5.4+ 中的回归而再次引入。(CVE-2006-7243、CVE-2015-4025)

- 由于未正确处理 HTTP 请求中的 multipart/form-data,因此 rfc1867.c 的 multipart_buffer_headers() 函数中存在缺陷。远程攻击者可以利用此缺陷引发 CPU 资源消耗,从而导致拒绝服务。
(CVE-2015-4024)

- 由于在遇到“\x00”字符时会截断路径名的 pcntl_exec 实现中存在缺陷,因此存在安全绕过漏洞。远程攻击者可利用此问题,通过构建的第一个参数绕过预期的扩展限制并执行任意文件。(CVE-2015-4026)

请注意,Nessus 没有测试此问题,而仅依赖于应用程序自我报告的版本号。

解决方案

升级至 PHP 版本 5.4.41 或更新版。

另见

http://php.net/ChangeLog-5.php#5.4.41

插件详情

严重性: Critical

ID: 83517

文件名: php_5_4_41.nasl

版本: 1.12

类型: remote

系列: CGI abuses

发布时间: 2015/5/18

最近更新时间: 2021/1/19

依存关系: php_version.nasl

风险信息

CVSS 分数来源: CVE-2015-4026

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No exploit is required

补丁发布日期: 2015/5/14

漏洞发布日期: 2006/12/18

参考资料信息

CVE: CVE-2006-7243, CVE-2015-2325, CVE-2015-2326, CVE-2015-4021, CVE-2015-4022, CVE-2015-4024, CVE-2015-4025, CVE-2015-4026

BID: 44951, 74700, 74902, 74903, 74904, 75056, 75174, 75175