phpMyAdmin 4.0.x < 4.0.10.9 / 4.2.x < 4.2.13.2 / 4.3.x < 4.3.11.1 信息泄露漏洞 (PMASA-2015-1)

medium Nessus 插件 ID 81818
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器托管受到信息泄露漏洞影响的 PHP 应用程序。

描述

根据其自我报告的版本号,远程 Web 服务器上托管的 phpMyAdmin 应用程序为低于 4.0.10.9 的 4.0.x、低于 4.2.13.2 的 4.2.x 或低于 4.3.11.1 的 4.3.x。因此,它会因未隐藏压缩 HTTPS 响应的长度而受到信息泄露漏洞的影响。这允许远程攻击者使用一系列构建的请求来通过 BREACH 攻击获得 CSRF 标记。

请注意,Nessus 尚未测试此问题,而是只依赖于应用程序自我报告的版本号。

解决方案

升级到 phpMyAdmin 4.0.10.9 / 4.2.13.2 / 4.3.11.1 或更高版本或者应用供应商公告中引用的修补程序。

另见

http://www.phpmyadmin.net/home_page/security/PMASA-2015-1.php

http://www.nessus.org/u?a4cc2198

http://www.nessus.org/u?11d0e38d

http://www.nessus.org/u?4b01e679

插件详情

严重性: Medium

ID: 81818

文件名: phpmyadmin_pmasa_2015_1.nasl

版本: 1.5

类型: remote

系列: CGI abuses

发布时间: 2015/3/13

最近更新时间: 2021/1/19

依存关系: phpMyAdmin_detect.nasl

配置: 启用偏执模式

风险信息

VPR

风险因素: Low

分数: 2.5

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: AV:N/AC:L/Au:N/C:P/I:N/A:N

时间矢量: E:U/RL:OF/RC:C

漏洞信息

CPE: cpe:/a:phpmyadmin:phpmyadmin

必需的 KB 项: www/PHP, installed_sw/phpMyAdmin, Settings/ParanoidReport

易利用性: No exploit is required

补丁发布日期: 2015/3/4

漏洞发布日期: 2015/3/4

参考资料信息

CVE: CVE-2015-2206

BID: 72949