Apache 2.4.x < 2.4.12 多个漏洞

medium Nessus 插件 ID 81126
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器受到多个漏洞影响。

描述

根据其标题,远程主机上运行的 Apache 2.4.x 版本低于 2.4.12。因此,该应用程序受到以下漏洞的影响:

- 在 mod_headers 模块中存在缺陷,可能导致在请求进程中 HTTP 尾端延迟替换 HTTP 标头,远程攻击者可利用此缺陷注入任意标头。这可能导致某些模块功能出错或显示为功能出错。(CVE-2013-5704)

- 在 mod_cache 模块中存在空指针取消引用缺陷。远程攻击者使用空 HTTP Content-Type 标头,能够使用此漏洞引起缓存转发代理配置崩溃,导致如果使用线程 MPM 则会拒绝服务。
(CVE-2014-3581)

- 在 mod_proxy_fcgi 模块中存在越界内存读取缺陷。攻击者使用远程 FastCGI 服务器发送长响应标头,能够利用此漏洞导致缓冲区过度读取,从而造成拒绝服务。(CVE-2014-3583)

- 当使用不同参数处理用于多个 Require 指令的 LuaAuthzProvider 时,在 mod_lua 模块中存在缺陷。攻击者可利用此漏洞绕过特意设置的访问限制。
(CVE-2014-8109)

请注意,Nessus 尚未测试这些问题,而是只依靠应用程序自我报告的版本号。

解决方案

升级至 Apache 2.4.12 或更高版本。此为,还需确保没有使用受影响的模块。

另见

https://archive.apache.org/dist/httpd/CHANGES_2.4.12

http://httpd.apache.org/security/vulnerabilities_24.html

插件详情

严重性: Medium

ID: 81126

文件名: apache_2_4_12.nasl

版本: 1.15

类型: combined

代理: windows, macosx, unix

系列: Web Servers

发布时间: 2015/2/2

最近更新时间: 2021/1/28

依存关系: apache_http_version.nasl, apache_http_server_nix_installed.nbin, apache_httpd_win_installed.nbin

风险信息

CVSS 分数来源: CVE-2013-5704

VPR

风险因素: Medium

分数: 4.5

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: AV:N/AC:L/Au:N/C:N/I:P/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Medium

基本分数: 5.3

时间分数: 4.6

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:apache:http_server

必需的 KB 项: installed_sw/Apache

易利用性: No known exploits are available

补丁发布日期: 2015/1/30

漏洞发布日期: 2013/10/19

参考资料信息

CVE: CVE-2013-5704, CVE-2014-3581, CVE-2014-3583, CVE-2014-8109

BID: 66550, 71656, 71657, 73040