PHP 5.6.x < 5.6.5 多种漏洞

critical Nessus 插件 ID 81082
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器使用受多种漏洞影响的 PHP 版本。

描述

根据其标题栏,远程主机上安装的 PHP 5.6.x 版本低于 5.6.5。因此,它受到多种漏洞的影响:

- 当使用 nmap 处理以哈希字符 (#) 开头但缺少换行符的无效文件时,文件“cgi_main.c”中存在越界读取缺陷。
远程攻击者可通过特别构建的 PHP 文件,利用此漏洞来泄露内存内容、造成拒绝服务或执行代码。(CVE-2014-9427)

-“gd_gif_in.c”的 GetCode_() 函数中存在越界读取问题。这允许远程攻击者泄露内存内容。(CVE-2014-9709)

- 由于未正确处理对象的序列化属性中的重复数字键,因此“var_unserializer.re”的 process_nested_data() 函数中存在一个释放后使用内存错误。远程攻击者可通过构建的反序列化方法调用,利用此漏洞执行任意代码。
(CVE-2015-0231)

-“exif.c”的 exif_process_unicode() 函数中存在缺陷,允许释放未初始化的指针。远程攻击者可通过 JPEG 图像中特别构建的 EXIF 数据,利用此漏洞造成拒绝服务或执行任意代码。(CVE-2015-0232)

请注意,Nessus 并不试图利用这些问题,而只依赖于应用程序自我报告的版本号。

解决方案

升级至 PHP 版本 5.6.5 或更新版。

另见

http://php.net/ChangeLog-5.php#5.6.5

https://bugs.php.net/bug.php?id=68618

https://bugs.php.net/bug.php?id=68710

https://bugs.php.net/bug.php?id=68799

插件详情

严重性: Critical

ID: 81082

文件名: php_5_6_5.nasl

版本: 1.19

类型: remote

系列: CGI abuses

发布时间: 2015/1/29

最近更新时间: 2021/1/19

依存关系: php_version.nasl

风险信息

CVSS 分数来源: CVE-2015-0231

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No exploit is required

补丁发布日期: 2015/1/22

漏洞发布日期: 2014/12/17

参考资料信息

CVE: CVE-2014-9425, CVE-2014-9427, CVE-2014-9652, CVE-2014-9709, CVE-2015-0231, CVE-2015-0232

BID: 71800, 71833, 72505, 72539, 72541, 73306