PHP 5.6.x < 5.6.2 多种漏洞

high Nessus 插件 ID 78547
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器使用受多种漏洞影响的 PHP 版本。

描述

根据其标题栏,远程主机上安装的 PHP 5.6.x 版本低于 5.6.2。因此,它受到以下漏洞的影响:

-“mkgmtime”函数中存在缓冲区溢出错误,可导致应用程序崩溃或任意代码执行。(CVE-2014-3668)

-“unserialize”函数中存在整数溢出错误,可能导致拒绝服务攻击。
请注意,这仅影响 32 位实例。
(CVE-2014-3669)

-“exif_thumbnail”函数中存在堆损坏错误,可导致应用程序崩溃或任意代码执行。(CVE-2014-3670)

- cURL 扩展的“ext/curl/interface.c”文件和 NULL 选项处理中存在输入验证错误,可导致信息泄露。(缺陷 #68089)

请注意,Nessus 并不试图利用这些问题,而只依赖于应用程序自我报告的版本号。

解决方案

升级至 PHP 版本 5.6.2 或更新版。

另见

http://www.php.net/ChangeLog-5.php#5.6.2

插件详情

严重性: High

ID: 78547

文件名: php_5_6_2.nasl

版本: 1.9

类型: remote

系列: CGI abuses

发布时间: 2014/10/17

最近更新时间: 2021/1/19

依存关系: php_version.nasl

风险信息

CVSS 分数来源: CVE-2014-3669

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No exploit is required

补丁发布日期: 2014/10/16

漏洞发布日期: 2014/10/16

参考资料信息

CVE: CVE-2014-3668, CVE-2014-3669, CVE-2014-3670

BID: 70611, 70665, 70666