Oracle Linux 6 / 7:xerces-j2 (ELSA-2014-1319)

high Nessus 插件 ID 77978

简介

远程 Oracle Linux 主机缺少一个或多个安全更新。

描述

来自 Red Hat 安全公告 2014:1319:

更新后的 xerces-j2 程序包修复了一个安全问题,现在可用于 Red Hat Enterprise Linux 6 和 7。

Red Hat 产品安全团队将此更新评级为具有中等安全影响。可从“参考”部分中的 CVE 链接获取通用漏洞评分系统 (CVSS) 基本分数,其给出了详细的严重性等级。

适用于 Java 的 Apache Xerces (Xerces-J) 具有高性能且符合标准,用于验证写入 Java 的 XML 解析器。xerces-j2 程序包提供 Xerces-J 版本 2。

在 Xerces-J 处理 XML 声明的方式中发现资源消耗问题。通过采用 Xerces-J 的应用程序进行解析时,远程攻击者可以使用具有较长伪属性名称的特别构建声明的 XML 文档导致该应用程序占用过多 CPU。(CVE-2013-4002)

建议所有 xerces-j2 用户升级这些更新后的程序包,其中包含用于修正此问题的向后移植的修补程序。必须重新启动使用 Xerces-J 的应用程序才能使此更新生效。

解决方案

更新受影响的 xerces-j2 程序包。

另见

https://oss.oracle.com/pipermail/el-errata/2014-September/004494.html

https://oss.oracle.com/pipermail/el-errata/2014-September/004495.html

插件详情

严重性: High

ID: 77978

文件名: oraclelinux_ELSA-2014-1319.nasl

版本: 1.9

类型: local

代理: unix

发布时间: 2014/9/30

最近更新时间: 2021/1/14

支持的传感器: Frictionless Assessment Agent, Nessus Agent

风险信息

VPR

风险因素: Low

分数: 3.5

CVSS v2

风险因素: High

基本分数: 7.1

时间分数: 5.3

矢量: AV:N/AC:M/Au:N/C:N/I:N/A:C

时间矢量: E:U/RL:OF/RC:C

漏洞信息

CPE: p-cpe:/a:oracle:linux:xerces-j2, p-cpe:/a:oracle:linux:xerces-j2-demo, p-cpe:/a:oracle:linux:xerces-j2-javadoc, p-cpe:/a:oracle:linux:xerces-j2-javadoc-apis, p-cpe:/a:oracle:linux:xerces-j2-javadoc-impl, p-cpe:/a:oracle:linux:xerces-j2-javadoc-other, p-cpe:/a:oracle:linux:xerces-j2-javadoc-xni, p-cpe:/a:oracle:linux:xerces-j2-scripts, cpe:/o:oracle:linux:6, cpe:/o:oracle:linux:7

必需的 KB 项: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

易利用性: No known exploits are available

补丁发布日期: 2014/9/29

漏洞发布日期: 2013/7/23

参考资料信息

CVE: CVE-2013-4002

BID: 61310

RHSA: 2014:1319