Fedora 20:glibc-2.18-14.fc20 (2014-9824)

high Nessus 插件 ID 77430
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Fedora 主机缺少安全更新。

描述

- 区域设置名称,包括从环境变量(LANG 和 LC_* 变量)中获得的名称,现在会受到更严格的语法正确性检查。现在,对于超长、不以斜线开头且包含斜线或包含“..”路径成分的区域设置名称,setlocale 将(因 EINVAL)失败。(CVE-2014-0475) 之前,在 AT_SECURE 模式(例如 SUID 程序中)下运行时,某些有效的区域设置名称会静默地被“C”区域设置替换。有了额外的检查,这不再必要。

- 删除了对可加载的 gconv 直译模块的支持,因为它完全不会工作。现在仍支持常规 gconv 转换模块。
(CVE-2014-5119)

请注意,Tenable Network Security 已直接从 Fedora 安全公告中提取上述描述块。Tenable 已尝试在不引入其他问题的情况下尽可能进行了自动整理和排版。

解决方案

更新受影响的 glibc 程序包。

另见

https://bugzilla.redhat.com/show_bug.cgi?id=1102353

https://bugzilla.redhat.com/show_bug.cgi?id=1129743

http://www.nessus.org/u?cbef587b

插件详情

严重性: High

ID: 77430

文件名: fedora_2014-9824.nasl

版本: 1.10

类型: local

代理: unix

发布时间: 2014/8/29

最近更新时间: 2021/1/11

依存关系: ssh_get_info.nasl

风险信息

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.9

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:POC/RL:OF/RC:C

漏洞信息

CPE: p-cpe:/a:fedoraproject:fedora:glibc, cpe:/o:fedoraproject:fedora:20

必需的 KB 项: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

可利用: true

易利用性: Exploits are available

补丁发布日期: 2014/8/28

参考资料信息

CVE: CVE-2014-0475, CVE-2014-5119

BID: 68505, 68983

FEDORA: 2014-9824