PHP 5.3.x < 5.3.29 多种漏洞

high Nessus 插件 ID 77285
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器使用受多种漏洞影响的 PHP 版本。

描述

根据其标题,安装在远程主机上的 PHP 版本是 5.3.x,比 5.3.29 更早。因此,它受到以下漏洞的影响:

- 在处理 DateInterval 对象时“ext/date/lib/parse_iso_intervals.c”文件中存在基于堆的缓冲区溢出错误,允许拒绝服务攻击。(CVE-2013-6712)

- 存在与 Fileinfo 扩展、复合文档格式 (CDF) 处理以及“cdf_read_short_sector”函数相关的边界检查错误。(CVE-2014-0207)

- 在处理特别构建的 CDF 文件时,在“src/cdf.c”中的“cdf_unpack_summary_info()”函数存在错误,会发生多个 file_printf 调用。
这可能导致依赖上下文的攻击者使用 PHP 破坏 Web 应用程序。(CVE-2014-0237)

- 在处理特别构建的 CDF 文件时,在“src/cdf.c”中的“cdf_read_property_info()”函数存在一个缺陷,会发生无限循环。这可能导致依赖上下文的攻击者使用 PHP 破坏 Web 应用程序。(CVE-2014-0238)

- 存在与标准 PHP 库 (SPL) 扩展和“unserialize”函数相关的类型混淆错误。(CVE-2014-3515)

- 存在与配置脚本和临时文件处理相关的错误,可能允许使用不安全文件。(CVE-2014-3981)

- 存在与“dns_get_record”函数相关的基于堆的缓冲区溢出错误,可能允许执行任意代码。(CVE-2014-4049)

- 在 printf 中存在越界读取。(缺陷 #67249)

请注意,Nessus 并不试图利用这些问题,而只依赖于应用程序自我报告的版本号。

此外请注意,版本 5.3.29 标志着结束对 PHP 5.3.x 分支的支持。

解决方案

升级至 PHP 版本 5.3.29 或更新版。

另见

http://php.net/archive/2014.php#id2014-08-14-1

http://www.php.net/ChangeLog-5.php#5.3.29

插件详情

严重性: High

ID: 77285

文件名: php_5_3_29.nasl

版本: 1.10

类型: remote

系列: CGI abuses

发布时间: 2014/8/20

最近更新时间: 2021/1/19

依存关系: php_version.nasl

风险信息

CVSS 分数来源: CVE-2014-3515

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.3

时间分数: 6.4

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No exploit is required

补丁发布日期: 2014/8/14

漏洞发布日期: 2013/11/27

参考资料信息

CVE: CVE-2013-6712, CVE-2014-0207, CVE-2014-0237, CVE-2014-0238, CVE-2014-3478, CVE-2014-3479, CVE-2014-3480, CVE-2014-3487, CVE-2014-3515, CVE-2014-3981, CVE-2014-4049, CVE-2014-4721

BID: 64018, 67759, 67765, 67837, 68007, 68120, 68237, 68238, 68239, 68241, 68243, 68423, 69271, 73385