PHP 5.4.x < 5.4.29“src/cdf.c”多种漏洞

medium Nessus 插件 ID 74291
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器使用受多种漏洞影响的 PHP 版本。

描述

根据其标题,远程主机上所安装的 PHP 5.4.x 版本低于 5.4.29。因此,它受到以下漏洞的影响:

- 在处理特别构建的 CDF 文件时,在“src/cdf.c”中的“cdf_unpack_summary_info()”函数存在错误,会发生多个 file_printf 调用。
这可能导致依赖上下文的攻击者使用 PHP 破坏 Web 应用程序。(CVE-2014-0237)

- 在处理特别构建的 CDF 文件时,在“src/cdf.c”中的“cdf_read_property_info()”函数存在一个缺陷,会发生无限循环。这可能导致依赖上下文的攻击者使用 PHP 破坏 Web 应用程序。(CVE-2014-0238) - 在 printf 里存在越界读取。(缺陷 #67249)

请注意,Nessus 并不试图利用这些问题,而只依赖于应用程序自我报告的版本号。

解决方案

升级至 PHP 版本 5.4.29 或更新版。

另见

http://www.php.net/ChangeLog-5.php#5.4.29

https://bugs.php.net/bug.php?id=67327

https://bugs.php.net/bug.php?id=67328

插件详情

严重性: Medium

ID: 74291

文件名: php_5_4_29.nasl

版本: 1.5

类型: remote

系列: CGI abuses

发布时间: 2014/6/3

最近更新时间: 2021/1/19

依存关系: php_version.nasl

风险信息

VPR

风险因素: Low

分数: 3.6

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: AV:N/AC:L/Au:N/C:N/I:N/A:P

时间矢量: E:U/RL:OF/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No exploit is required

补丁发布日期: 2014/5/29

漏洞发布日期: 2014/5/22

参考资料信息

CVE: CVE-2014-0237, CVE-2014-0238

BID: 67759, 67765, 69271