PHP 5.4.x < 5.4.28 FPM Unix 套接字不安全权限升级

high Nessus 插件 ID 73862
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器采用的 PHP 版本可能受到权限升级漏洞的影响。

描述

根据其标题,远程主机上所安装的 PHP 5.4.x 版本低于 5.4.28。因此,可能遭受权限升级漏洞影响。

当为 Unix 设置套接字时,在 FastCGI 进程管理器 (FPM) 中存在漏洞。这可能允许远程攻击者在访问套接字后获取较高的权限。

请注意此插件并不试图利用这些漏洞,而只依赖于 PHP 自我报告的版本号。

解决方案

升级至 PHP 版本 5.4.28 或更新版。

另见

http://www.php.net/ChangeLog-5.php#5.4.28

https://bugs.php.net/bug.php?id=67060

http://www.nessus.org/u?a7b8dfdd

插件详情

严重性: High

ID: 73862

文件名: php_5_4_28.nasl

版本: 1.9

类型: remote

系列: CGI abuses

发布时间: 2014/5/5

最近更新时间: 2021/1/19

依存关系: php_version.nasl

风险信息

CVSS 分数来源: CVE-2014-0185

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: High

基本分数: 7.2

时间分数: 5.3

矢量: AV:L/AC:L/Au:N/C:C/I:C/A:C

时间矢量: E:U/RL:OF/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No exploit is required

补丁发布日期: 2014/5/1

漏洞发布日期: 2014/4/12

参考资料信息

CVE: CVE-2014-0185

BID: 67118