GLSA-201401-33:Perl Digest-Base 模块:任意代码执行

high Nessus 插件 ID 72207
全新!漏洞优先级评级 (VPR)

Tenable 测算每个漏洞的动态 VPR。VPR 将漏洞信息与威胁情报和机器学习算法相结合,预测哪些漏洞最有可能在攻击中被利用。了解详细信息: VPR 的定义及其与 CVSS 的区别。

VPR 得分: 6.7

简介

远程 Gentoo 主机缺少一个或多个与安全有关的修补程序。

描述

远程主机受到 GLSA-201401-33 中所述漏洞的影响(Perl Digest-Base 模块:任意代码执行)

由于“Digest->new()”函数在“eval()”调用中使用输入之前未正确审查输入,因此存在漏洞。
影响:

漏洞可能允许攻击者执行任意代码。
变通方案:

目前无任何已知的变通方案。

解决方案

所有 Digest-Base 模块用户都应升级到最新版本:# emerge --sync # emerge --ask --oneshot --verbose '>=perl-core/digest-base-1.170.0'

另见

https://security.gentoo.org/glsa/201401-33

插件详情

严重性: High

ID: 72207

文件名: gentoo_GLSA-201401-33.nasl

版本: 1.7

类型: local

发布时间: 2014/1/30

最近更新时间: 2021/1/6

依存关系: ssh_get_info.nasl

风险信息

风险因素: High

VPR 得分: 6.7

CVSS v2.0

基本分数: 7.5

时间分数: 5.9

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:POC/RL:OF/RC:C

漏洞信息

CPE: p-cpe:/a:gentoo:linux:digest-base, cpe:/o:gentoo:linux

必需的 KB 项: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

可利用: true

易利用性: Exploits are available

补丁发布日期: 2014/1/29

参考资料信息

CVE: CVE-2011-3597

BID: 49911

GLSA: 201401-33